Support » Plugins and Hacks » The Events Calendar » [Resolved] [Plugin: The Events Calendar] Always getting "event has passed" message

[Resolved] [Plugin: The Events Calendar] Always getting "event has passed" message

Viewing 10 replies - 1 through 10 (of 10 total)
  • I have this exact problem too…. anyone? If I find a solution I will share.

    Seems to have something to do with single.php. See the following threads:



    Also seems to be a problem that has arisen for several people specifically today.

    They responded and acknowledged that it is a bug. Hopefully they fix it soon. tri.be/support/forums/topic/the-events-calendar-2-0-5-events-passed/#post-17190

    Hi Chris,
    Thank’s for your feedback. So it seems we’re not alone 🙂
    Hope they fix it soon indeed!


    Same problem with the free version (2.0.5). But I could get rid of it by setting “UTC-2” for the timezone in the wordpress settings. It did not vanish for “UTC+2”, though.

    Plugin Author Rob La Gatta


    Hi all. Thanks for the notes here; this was an issue we discovered upon launching the 2.0.5 code yesterday and have since patched this morning. If you re-download and install the 2.0.5 code again, the issue should be resolved for all time zone settings regardless of whether a city or UTC option was selected from the dropdown. Please make sure to clear your cache and resave permalinks after installing the new code.

    If any issue persists, let us know. Apologies for the inconvenience and thanks for bearing with us.

    Excellent, it is fixed. For those who are confused on this like I was, you have to change the time zone settings not under The Events Calendar area but in the general WordPress settings. So that would be “Settings > General > TimeZone (in the middle of the page).

    Perfect. Works now independent of timezone settings.

    Works here too. Thx all!

    Plugin Author Rob La Gatta


    Wonderful to hear! Thanks for confirming, folks. If you’d be so kind as to mark us with a “Works” here on the OS repo, we sure would appreciate it.

    Meanwhile, let us know if you have any other problems down the road. Thanks again for your support.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] [Plugin: The Events Calendar] Always getting "event has passed" message’ is closed to new replies.
Skip to toolbar