Support » Plugin: YITH WooCommerce Wishlist » Plugin text translation problem

  • Hi,

    I am using the free version of YITH WooCommerce Wishlist. I have started to translate the plugin in my language by using .po file and PoEditor and have managed to translate almost everything.

    The problem is that some translation is accepted (as Remove, Choose options etc), but the translation of the text that can be customized in backend settings is not, es. text for “Add to Wishlist” text-Add to Wishlist, “Browse wishlist” text-Browse Wishlist, “Product added” text -Product added! etc.

    How I can translate this custom text (Add to Wishlist,Browse Wishlist etc)? Can I add some string in the backend settings or some other way?

    Thank you

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author YITHEMES

    (@yithemes)

    Hi elena

    The strings that you see in .po file are only placeholders
    Once plugin is installed, and its options saved, this placeholders will be saved on database, and the value will always be the same, if user doesn’t change it from admin panel

    If you want your translated placeholder to appear on backend, you should “Reset Default” options: in this way that all wishlist settings in db will be ereased, and placeholder will be used once again to populate settings form

    Hope this helps
    Have a nice day 🙂

    I have done as you have written and still no change.
    These default strings have been translated in the .po file, I have clicked on Reset Defaults and Save Changes, but nothing changes.

    I am sending you screenshots.

    Wishlist plugin admin

    Add to wishlist

    Browse wishlist

    Wishlist preview

    Plugin Author YITHEMES

    (@yithemes)

    Hi again Elena

    If you wish to change values of these strings, to match your language, why don’t you simply change theme inside settings panel? 🙂

    I think this would solve the problem without any additional effort

    Let me know if this may be a valid solution for you
    Have a nice day

    In which settings panel?

    When I go to YITH plugins> Wishlist I get only to tabs one is Settings and there is no option for theme change and the other one is Colors and you can change only buttons’ colors.

    Can you please explain me more in detail, possibly with screenshots, how I can finally make my translation work?

    Thank you

    Plugin Author YITHEMES

    (@yithemes)

    Hi Elena

    all you have to do is navigate to WP Dashboard -> YITH Plugins -> Wishlist -> Settings, find options for “Add to Wishlist” text, “Browse Wishlist” text, “Product already in wishlist” text and “Product Added” text, put in this fields the strings you want to use, in your language, and finally save options as they are

    This should solve the problem 🙂
    Please, let me know if this works
    Have a nice day

    I am aware of the possibility to change the text in WP Dashboard -> YITH Plugins -> Wishlist -> Settings, “Add to Wishlist” text; but this won’t work for bilingual e-shop (English and Macedonian) as mine is. If I write here the text instead in English in Macedonian, when I change my language in the frontend, this text in Macedonian will remain in Macedonian also when I switch to English language in the frontend!

    Here in this image you can see that I have written in the string the translation in Macedonian:

    and here how it’s shown when in frontend I switch the language from MK to EN. It remains in Macedonian!

    I need when I am on the MK version in the frontend this text “Add to Wishlist” to be shown in Macedonian (ВО ОМИЛЕНИ) and when I switch the language in the frontend to English to be in EN (Add to Wishlist).

    I have even tried to switch languages in backend to MK and EN and write different text, but this is not accepted as translation in the frontend.

    I have even tried to make classical string in the backend
    WP_Add_Wishlist” alt=”” />

    and to insert it in the .po file for EN and MK language, but when the file is edited with Poedit it is not possible to substitute Source text with the string created by me (WP_Add_Wishlist).

    I hope that now the problem is more clear 🙂

    Is there any way to translate this string (Add to Wishlist) so when I am on the EN version of the e-shop to be Add to Wishlist and when I am on the MK version to be Во кошничка ???

    • This reply was modified 2 years, 7 months ago by  .
    • This reply was modified 2 years, 7 months ago by  .
    Plugin Author YITHEMES

    (@yithemes)

    Hi Elena

    Everything is more clear now 🙂
    Could you please tell me what plugin are you using to implement multi-lingual functionality inside WordPress?

    We offer official support for WPML, but I’ll try to help you with any multilingual plugin 🙂

    Please, let me know
    Have a nice day

    I use qTranslate in combination of the plugins qTranslate support for WooCommerce By Michel Weimerskirch , qTranslate-X By qTranslate Team and WooCommerce & qTranslate-X By qTranslate Team .

    When I use posts and WooCommerce products I have 2 tabs for text input (one for MK and other for EN). But when I am in YITH Wishlist backend settings I don’t see these 2 tabs.

    How I can translate the custom stings in YITH Wishlist (as text for “Add to Wishlist” text-Add to Wishlist, “Browse wishlist” text-Browse Wishlist, “Product added” text -Product added! etc.)by using qTranslate plugin?

    Thank you

    Hi Elena,

    In Qtranslate settings >> integration >> Custom filters field

    You need to manually add the filter of the related field so that Qtranslate will detect it as a translatable field and add a blue border on the left.

    I am bumping into the same problem right now and I need to know the filter name for that very field.

    Dear Yith team can you give us that?

    Thanks

    Hi,

    Found the solution actually, use id field instead of the filter one

    Qtranslate settings >> integration >> Custom fields >> id

    Add the following: #yith_wcwl_wishlist_title #yith_wcwl_browse_wishlist_text #yith_wcwl_already_in_wishlist_text #yith_wcwl_product_added_text #yith_wcwl_add_to_cart_text

    Then go to YITH WISHLIST PLUGIN SETTINGS and change every input fields with the following format:

    [:en][:fr] if your website has English and French for example.

    [:en]This is the English text[:fr]This is the French text[:]

    Then click save. It should now work fine and only display the relevant language

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Plugin text translation problem’ is closed to new replies.