Support » Plugin: Text Obfuscator » [Plugin: Text Obfuscator] Error message foreach() line 212

  • Resolved FenyX

    (@fenyx)


    I had some minor problems with this plugin on one of my blogs but Jonathon Wardman helped me to solve this issues then it worked fine. So fine that I’ve decided to test Text Obfuscator on another blog. But now the post title and content contain the following error:

    Warning: Invalid argument supplied for foreach() in /home/myname/domains/myblog.com/public_html/wp-content/plugins/text-obfuscator/text-obfuscator.php on line 212

    Here is the code from the line 208 to 224:

    function obfuscator_filter( $content, $content_type = 'posts' ) {
    
    	$replacementData = get_option( 'obfuscator_replacements' );
    	$replacementTokens = $replacementValues = array();
    	foreach ( $replacementData AS $replacementItem ) {
    		if ( ! isset( $replacementItem['location'] ) || ( 'post' == $replacementItem['location'] ) ) {
    			if ( ! isset( $replacementItem[$content_type] ) || ( true == $replacementItem[$content_type] ) ) {
    				if ( $replacementElements = obfuscator_build_replacement_elements( $replacementItem ) ) {
    					$replacementTokens[] = $replacementElements['token'];
    					$replacementValues[] = $replacementElements['value'];
    				}
    			}
    		}
    	}
    	return preg_replace( $replacementTokens, $replacementValues, $content );
    
    }

    I don’t know what to do but I know that I would really like to use this plugin on my pro blog. As I am a real PHP noob, I would appreciate any help to try resolving this problem. Thanks in advance ๐Ÿ™‚

    http://wordpress.org/extend/plugins/text-obfuscator/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Is your server running PHP5? I have often seen foreach() errors when a plug-in requires PHP5 but the server is only running PHP4. Just a guess, but perhaps worth ruling out.

    Yes, it’s running PHP5. But thanks anyway for your suggestion. Merci ๐Ÿ˜‰

    โ€ข PHP Version : 5.2.17
    โ€ข PHP Safe Mode : Off

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Oh, darn. Is your other blog (where it’s running OK) also running 3.1.1, or an earlier version?

    It’s the exact same version (updated today), near the same plugins are installed… Only the theme really changes. Ha… and also the language. First blog was an english version of WordPress, the blog where I’m encountering problems now is a french version of WP.

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Could the French accents be throwing the plug-in off? C’est bien plate, รงa! ๐Ÿ˜‰

    If you switch the blog to English, does the same error come up? (Caveat: I don’t know what may happen if you switch the language in terms of losing any data or settings ideally you should test this on a local or development server first.)

    Everything is configured as UTF-8 on this blog but, as you say, it may be a cause. Btw I’ve forgotten to explain that I’ve just installed and activated this plugin without adding any rule or setting yet.

    I’ll follow your advice and will do a full backup via my hosting control panel in addition of doing a database backup. I also don’t know how easy it is to switch WP language as I always install the right version language and never have to change it. Do you think that modifying the wp-config.php file would be enough?

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Do you think that modifying the wp-config.php file would be enough?

    Unfortunately I don’t know and don’t want to tell you the wrong thing – hopefully someone else will chime in.

    So yes, finally it was easy to switch language. But the problem is the same when WP is set to en-US (default), so I think that this issue isn’t related to the blog’s language.

    I’ve also left a message to the plugin’s author but I’ve not received his answer yet.

    Plugin Author confuzzledduck

    (@confuzzledduck)

    I think the key here is that you’re running the plugin without any settings so the arrays simply don’t exist.

    I have just pushed an update to the trunk which should remove the warnings in this situation. Can you give this (download link) a try and let me know if it resolves the problem for you?

    I’m currently working on the 1.3 version of the plugin which gives the admin pages an overhaul and adds some additional functionality. I’ll push this change to that version too, but I probably wont release this change as a full version on it’s own.

    Sorry for the response delay. I’ve tried it today morning and the problem seems to be solved. It’s the second time you save me, lol. Thanks a lot! ๐Ÿ˜‰

    If you need beta testers for suture releases, please add me to the list.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Text Obfuscator] Error message foreach() line 212’ is closed to new replies.