Support » Plugins » Plugin: Text Control – suddenly stops working

  • I’ve been thrilled to be using the plugin Text Control and now, without changing anything in the admin or updating 1.5, it has “stopped” working. Oh, it works on the individual posts (I save and return to edit and it’s there at the bottom), but the global functions are missing from the Options Screen. The link to the panel “Text Control” is there but nothing but the WordPress and Firefox logo appears.

    It was working great a couple days ago – now what? This has been reported by at least one other person. The above link goes to the wp-plugins repository, and I’ve looked at the author’s site and there is no reference to this plugin anywhere, so other than sending a direct note to the author (I will), there is no place to get more info to see if anyone has had this problem and found a fix.

    Anyone know? Very strange. I am DESPERATE to get this working immediately!

Viewing 6 replies - 1 through 6 (of 6 total)
  • bump

    Well, I figured it out, sorta. I had to do a reinstall of WordPress, upgrade style, and now it is working just fine. By the way, the plugin author worked over time to help me figure this out. Awesome!

    Wish I knew what triggered it.

    I’m having a similar problem–I’ve NEVER been able to get the Text Control plugin to completely work on my blog. It shows up in the options fine, but it’s not showing up at the bottom of my edit post or edit page forms.

    It’s working OK on a development setup on my WinXP laptop (Apache, PHP, MySQL), but not on my web host (Dreamhost) at all! The plugin activates fine, the options seem to “take” (they’re stored in the wp_option table OK), but the menus don’t show up on the bottom of my page.

    I’m also contacting the author, but I hope someone here is willing to help.


    I am having this problem too. I am also hosted with Dreamhost. Could it have anyting to do with their turning off of allow_url_fopen PHP configuration on all servers (April 20th)?

    I don’t know much at all about PHP, this seemed coincidental, does anyone know?




    mine worked for a day i think, and then mysteriously stopped working, and Im not on dreamhost — my isp allows literally everything. It stopped, and Ive not sweated it, but would love to see a solution.

    Ahah…for those of you who can’t get Text Control to show up on the individual posts (only the config menu shows up in options), I figured out why mine doesn’t work (I think). I host with Dreamhost and I installed my first blog before they had one click installs (so, manually) on a really old domain. Turns out new domains and any time you use a one click install, your domain automatically goes into “Run PHP as CGI” mode. All my new blogs were running in this manner and none of them are able to use Text Control. I just switched my old domain from regular PHP to PHP as CGI and whatddya know? Text Control doesn’t work there anymore. Fortunately Dreamhost allows you to do either with PHP though they strongly reccomend running PHP as CGI.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Plugin: Text Control – suddenly stops working’ is closed to new replies.