WordPress.org

Forums

Testimonials Widget
[resolved] Warning: call_user_func_array() ?? (9 posts)

  1. cra2
    Member
    Posted 2 years ago #

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'Testimonials_Widget::get_testimonials_scripts' was given in /home/american/public_html/wp-includes/plugin.php on line 403

    I updated the Testimonials widget to v2.0.1 and now I see the above error message on my site, at the bottom just below the footer. But the Testimonials widget does seem to be working.

    Anyone know what this error is saying or how to resolve it?

    EDIT: And now I notice that the testimonials aren't cycling through every 10 seconds like they were before. The refresh interval is still set for 10 seconds, but the only way to see a new testimonial is via a reload of the page. Is that related to the error I cited above?

    http://wordpress.org/extend/plugins/testimonials-widget/

  2. adwraj
    Member
    Posted 2 years ago #

    I'm having the same problem here.. Any solutions for this ?

  3. cra2
    Member
    Posted 2 years ago #

    I posted a bounty of $10 on WP-Questions and got the following answer.
    Hope it helps you.
    Although this doesn't resolve the issue - we need the plugin developer to include a similar patch in an update.

    The issue is here

    add_action( 'wp_footer', 'Testimonials_Widget::get_testimonials_scripts', 20 ); Line 350

    It should be

    add_action( 'wp_footer', array( &$this, 'Testimonials_Widget_Widget' ), 20 );

    Thats why the error says expecting a valid callback, because the first callback is wrong...

  4. Cyndi Papia
    Member
    Posted 2 years ago #

    I reinstalled the older version for now....thanks for looking into it!

  5. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    I'm checking on this. Do you know your PHP versions?

  6. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    Release 2.0.2 tries wp_footer's add_filter differently.

    Please let me know how it goes.

  7. cra2
    Member
    Posted 2 years ago #

    well, the solution I mentioned above worked just fine.
    Did you copy that into your update or did you solve it differently?

    I'm hesitant to update since mine's working fine now.
    Anyone tried the new 2.0.2 solution?

  8. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    I think the current release is 2.1.3 and I used a slightly different solution for the call back error. Others have mentioned that the fix worked.

  9. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    Any luck getting testimonials widget plugin to work for you?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Testimonials Widget
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic