• Resolved Marisa


    Hello, I encounter an error while activating the plugin, report the following error.

    MailPoet Error: PDOException: SQLSTATE [42S02]: Base table or view not found: 1146 Table ‘unavitaacolori.ItTRI940e9_mailpoet_settings’ doesn’t exist in /data/vhosts/unavitaacolori.it/htdocs/wp-content/plugins/mailpoet/vendor- prefixed / doctrine / dbal / lib / Doctrine / DBAL / Driver / PDOConnection.php: 78

    I have installed wp 5.9 and all the plugins are up to date but for a few days I have encountered this problem that does not allow me to activate the mailpoet plugin.
    Could you help me understand why?
    Thanks so much

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi, I’ve the same problem than Marisa with WP 5.9 and the last version of MailPoet 3 (New) (version 3.79.0) and PHP version 7.4.25.
    Thanks a lot

    Plugin Support Gui A. a11n


    Hi there @mirobolus and @unavitaacolori,

    Thanks for reaching out!

    That error indicates that there is a table missing on your website’s database.

    I’d recommend re-installing your MailPoet plugin to see if it will be created properly: Re-installing / Updating the Plugin via FTP.

    In many cases, this resolves the issue. Please, let us know how that goes!

    Thread Starter Marisa


    I have uninstalled, cleared the database of all related tables and reinstalled. the problem still arises. I also tried to deactivate all plugins and activate only mailpoet but the problem persists.

    Plugin Support Gui A. a11n


    Thanks for giving that a try!

    I’ve done some more research and found a similar case on our Premium support where the site was using PHP 8.1 and WordPress 5.8.2, which only supports PHP 8.0.

    You can see the compatibility chart here:

    One of the differences is in the way PHP handles mysqli_driver errors.
    Before PHP 8.1 the errors are silent, and the WordPress database functions rely on this type of error handling.

    From 8.1 mysqli_driver errors are not silent by default. On the WordPress 5.9 release, the database functions have been updated to handle this change.

    Can you please check what’s your WordPress and PHP versions and let us know?

    Thread Starter Marisa


    Wordpress version 5.9
    PHP 7.4.27 app fpm Apache

    Plugin Support Elvira K. a11n


    Hi there @unavitaacolori,

    I apologize for the late reply.

    We’ve seen another case with the same error and it seemed to be arising from a corrupt database or old database engine.

    Can you please reach out to your hosting to see if they can check your database for corruption? They can also create a new database and migrate all the data. We’ve seen such steps help before.

    Please don’t hesitate to contact us back if you need further assistance!

    Plugin Support Ojoma a11n


    Hello @unavitaacolori

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    Of course, feel free to reach out to us at any time if you need further assistance or you have other questions and we’d be happy to help.

    Have a great day!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘plugin table error’ is closed to new replies.