Support » Plugins and Hacks » [Plugin: Tabbed Widgets] Broken in WordPress 3.3

[Plugin: Tabbed Widgets] Broken in WordPress 3.3

Viewing 15 replies - 1 through 15 (of 19 total)
  • Don’t work “Style as: tabs”.

    Same here, all there tabs are listed below each other, no tabs.

    I can also confirm that this plugin is completely non-functional in WP 3.3

    + 1

    Here’s the error I’m getting with tabs. (Note: the accordian setting seems to work, and the “tabs-nav” is properly appended in init-plugin.js)

    $(".tw-tabs", this).tabs is not a function
    Line 51

    Okay. I’m hardly a wordpress pro, but I got this to work on WordPress 3.3 by forcing “jquery.ui.tabs.min.js” to load by placing the following line in the addHeader() function of tabbed-widgets.php in the Tabbed Widgets plugin:

    wp_enqueue_script('jquery-ui-tabs',  $this->plugin_path . 'js/jquery-ui-custom.min.js', array('jquery'), false, true);

    Maybe that’ll help.

    You are the best. Now it’s work again. Thanks!!!!
    Du bist der beste @verlierer. So läuft es wieder rund. Danke!!!!!!!!!!!!

    Ahhhh brilliant – you’re a champion!

    thank you, that worked right away after adding the code to tabbed-widgets.php file.

    Sorry to bother you.

    Please I placed this code just below function addHeader() {
    and just above a similar code that I found there only that that one seems to be for the accordion. Somehow, it still does not work. Can you pls advise on the right place to place the code in the tabbed-widgets.php file?

    this is how mine looks now and it works:

    function addHeader() {
    		wp_enqueue_script('jquery-ui-tabs',  $this->plugin_path . 'js/jquery-ui-custom.min.js', array('jquery'), false, true);
    		wp_enqueue_script('jquery-ui-accordion',  $this->plugin_path . 'js/jquery-ui-custom.min.js', array('jquery'), false, true);
    		wp_enqueue_script('jquery-ui-cookie',  $this->plugin_path . 'js/jquery-cookie.min.js', array('jquery-ui-accordion'), false, true);

    good luck.

    Hi guys,

    I am also using wordpress 3.3. with this widget and for me it worked with small tweaking in add header function in tabbed-widgets.php. Here is my add_header function

    function addHeader() {
      wp_enqueue_script('jquery-ui-tabs',  $this->plugin_path . 'js/jquery-ui-custom.min.js', array('jquery'), false, false);
      wp_enqueue_script('jquery-ui-accordion',  $this->plugin_path . 'js/jquery-ui-custom.min.js', array('jquery'), false, false);
      wp_enqueue_script('jquery-ui-cookie',  $this->plugin_path . 'js/jquery-cookie.min.js', array('jquery-ui-accordion'), false, false);
      // Add default widgets styles
      wp_enqueue_style('tabbed-widgets', $this->plugin_path . 'css/tabbed-widgets.css');
      if (get_current_theme() == 'Twenty Ten')
       wp_enqueue_style('tabbed-widgets-2010', $this->plugin_path . 'css/twenty-ten.css');

    Hope it helps

    So glad others are actually posting their solutions. Thanks to you all. Saved me at least an hour of debugging.



    Hi all,

    I’m having the same issue once I upgraded to wp 3.3. I tried the solutions suggested but still no luck. I’ve also re-installed the plugin, and disabled all others without any success.

    I’m at a loss and hoping there are some other solutions out there.

    Here is the site. The tabbed areas should be “latest headlines” & “hvwm library” in the sidebar below the big quote


    I had the same issue, verlierer’s solution fixed it for me on 3 different sites.

    Thank you!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: Tabbed Widgets] Broken in WordPress 3.3’ is closed to new replies.