SyntaxHighlighter Evolved
[resolved] Syntax highlighter Error (5 posts)

  1. jlengrand
    Posted 3 years ago #

    Hi all,

    Since this morning, the SyntaxHighlighter Evolved won't work on my website anymore.
    I don't know what happened exactly, but deactivating, reinstalling and using an old version of my css stylesheet did not solve the problem.

    You can see what happens here : http://www.lengrand.fr
    The only noticable thing I did was to install/remove the Front Page Excluded Categories plugin. (http://wordpress.org/extend/plugins/front-page-excluded-categories/).

    When using firefox developer tools, I got this error :

    Error: SyntaxHighlighter is not defined
    Source File: http://www.lengrand.fr/
    Line: 960

    which highlights this line :
    SyntaxHighlighter.config.clipboardSwf = 'http://www.lengrand.fr/wp-content/plugins/syntaxhighlighter/syntaxhighlighter2/scripts/clipboard.swf';

    I checked and the .swf file is present.

    Would you have any ideas that could solve the issue?
    I am pretty inexperienced with php, so any help would be greatly appreciated.

    Thanks by advance !


  2. Alex Mills (Viper007Bond)
    Plugin Author

    Posted 3 years ago #

    I guess you fixed it? It seems to be working fine for me. :)

    If not, clear your browser cache.

  3. jlengrand
    Posted 3 years ago #

    Hi Alex,

    Thanks for the message.
    I finally fixed the message indeed (as you may ahve seen on my blog :p).

    The problem was (and is still) coming from a plugin called jetpack, and especially its gravatar part.

    A misplaced comment blocked a </script> tag, and it was disbling the syntax highlighter javascript code. . .

    I sent a mail to the dev team of jetpack, but still did not get any answer. I 'll let you know ;)

  4. Alex Mills (Viper007Bond)
    Plugin Author

    Posted 3 years ago #

    Weird, I run Jetpack on my site and have the Gravatar module enabled. Hmm.

  5. jlengrand
    Posted 3 years ago #

    Wierd indeed.

    I send a mail to Jetpack support some days ago but did not get any answer yet.

    Aniyway, I'm currently trying to reduce the number of plugins I use and enhance the time load of the blog.
    So Jetpack is not part oy my activated plugins anymore :).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SyntaxHighlighter Evolved
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic