Support » Plugin: SyntaxHighlighter Evolved » [Plugin: SyntaxHighlighter Evolved] HTML entities

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Alex Mills (Viper007Bond)


    Try using HTML view to remove the possibility that it’s the visual editor that’s causing the problems.

    I am using the HTML editor. I even disabled the visual editor in my profile settings.

    Thanks for the help.

    Plugin Author Alex Mills (Viper007Bond)


    Can you please post the code here so I can copy/paste it and attempt to reproduce? Thanks.

    Sure thing…

    require ‘rubygems’
    require ‘activesupport’
    dt =
    puts dt.to_f
    # => 1240455468.91318
    t = YAML.load(dt.to_yaml)
    # => Time
    puts t.to_f
    # => 1240455468.0

    Plugin Author Alex Mills (Viper007Bond)


    I can’t reproduce this. I tried on both my localhost test blog and (where the plugin is also in use):

    I copy/pasted your above code directly into the HTML editor and hit publish.

    That’s strange. That example is working for me now too. Maybe I was seeing a cached version of the page or something. Can you try this one?

    module ActiveRecord
    module Associations
    module ClassMethods

    def construct_finder_sql_for_association_limiting(options, join_dependency)
    scope = scope(:find) || {}
    order = [options[:order], scope[:order]].compact.join(', ')

    # Only join tables referenced in order or conditions since this is particularly slow on the pre-query.
    tables_from_conditions = conditions_tables(options)
    tables_from_order = order_tables(options)
    all_tables = tables_from_conditions + tables_from_order
    distinct_join_associations ={|table|

    is_distinct = !options[:joins].blank? || include_eager_conditions?(options, tables_from_conditions) || include_eager_order?(options, tables_from_order)
    sql = "SELECT "
    if is_distinct
    sql << connection.distinct("#{connection.quote_table_name table_name}.#{primary_key}", order)
    sql << primary_key
    sql << " FROM #{connection.quote_table_name table_name} "

    if is_distinct
    sql << distinct_join_associations.collect(&:association_join).join
    add_joins!(sql, options, scope)

    add_conditions!(sql, options[:conditions], scope)
    add_group!(sql, options[:group], scope)

    if order and is_distinct
    connection.add_order_by_for_association_limiting!(sql, :order => order)
    add_order!(sql, options[:order], scope)

    add_limit!(sql, options, scope)

    return sanitize_sql(sql)


    Here’s a pastie for better formatting:

    Plugin Author Alex Mills (Viper007Bond)


    Also works fine for me. Dunno what to tell ya.

    Ok, something really weird is going on. I think my WordPress install just got into a weird state.

    So when I preview that example code, it looks messed up for me, but then I updated the post and it looked fine. Then I previewed it again after the update and it still looked fine.

    So I thought maybe it’s the initial preview before you publish that is messed up. So I made a new post to test it… and everything worked fine. Ugh, frustrating. Computers (and computer programs) are supposed to be deterministic… 😛

    I guess it could be a multitude of things… the Blogger importer pulling in posts incorrectly, maybe it was the way I copied and pasted the code, dunno.

    Anyway, sorry for wasting your time.

    Plugin Author Alex Mills (Viper007Bond)


    It could be an issue with my plugin as preview may not use the same filters.

    Either way don’t rely on preview to debug things. 🙂

    Charles Merriam


    Just to let you know, I had a similar problem with a similar solution.

    • For an unpublished draft, preview works correctly
    • For a published article, preview does not work correctly

    Is not the precision of computer science truly a thing of awe?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: SyntaxHighlighter Evolved] HTML entities’ is closed to new replies.