WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Syndicate Press] [Synidicate Press] Failed to get content

[Resolved] [Plugin: Syndicate Press] [Synidicate Press] Failed to get content

Viewing 15 replies - 16 through 30 (of 42 total)
  • Plugin Author SP developer

    @hranchfundi

    Thanks for providing the feed URL. I tried it and cannot get the content either. It has been quite a while since I have run into a feed that failed to parse. I’ll give a look and seen what is going on.

    Plugin Author SP developer

    @hranchfundi

    It appears that the Syndicate Press download client is unable to download the feed content from your feed URL. I can obtain the feed when using firefox. Do you have a .htaccess set on your server that blocks non-standard browser clients?

    No htaccess applied.

    Two other sites I tried, again, among others:

    http://vetinformed.com/speakingofveterans/feed
    http://bobschecter.com/feed

    Still Failed.

    Plugin Author SP developer

    @hranchfundi

    Thanks for the links.

    Deeper investigation shows that your server is returning a 301 Permanent Move message for the feed URL. The feed down-loader in Syndicate Press does not currently handle redirect following. This also explains why the browser followed the redirect, but the SP feed down-loader did not.

    Here is the header returned by your server:
    HTTP/1.1 301 Moved Permanently Date: Wed, 26 Oct 2011 04:14:01 GMT Server: Apache X-Pingback: http://salamiandeggs.com/xmlrpc.php ETag: “697b18753ce3834e94a6d8633a339bc9” Last-Modified: Tue, 25 Oct 2011 15:18:37 GMT Location: http://salamiandeggs.com/feed/ Content-Length: 0 Connection: close Content-Type: text/html

    Over the several years of SP being out in the public release, your sites are the first I have encountered using permanent move of the rss feed. I will look into supporting redirect following in Syndicate Press for a future release.

    As a side note, a whois query shows that bobschecter.com is being hosted on godaddy servers. I did a quick google search for “godaddy wordpress 301 redirect rss” and found lots of responses about weird 301 redirects with godaddy hosting. Not to say there is anything wrong with that, but it is curious. I still hope to enable 301 redirect handling in SP, but this at least provides a root cause to the issue.

    GoDaddy sucks. I’m stuck there for a while.

    Hi

    I have found an issue with when I add a name for a feed.

    No name in the feed, works fine, but when i add the name i get the following:

    Failed to get content from ‘name http://www.nameofsite.co.uk/feed/rss/

    Please help !

    Nik

    Plugin Author SP developer

    @hranchfundi

    Hi Nik,
    please provide the feed URL and EXACT line you are putting into the feed text area.

    Thanks.

    http://www.aimeefuller.co.uk/feed/rss/ is the url, when I use that with [sp# all] it works fine.

    But when i change to include a name:

    aimee http://www.aimeefuller.co.uk/feed/rss/‘ with

    [sp# aimee]

    I get:

    Failed to get content from ‘aimee http://www.aimeefuller.co.uk/feed/rss/

    Danke !

    Plugin Author SP developer

    @hranchfundi

    Hi nikco,
    you need to put a PIPE ‘|’ character in between the name and the URL.

    It should look like this:

    aimee|http://www.aimeefuller.co.uk/feed/rss/

    Ahh ok thanks a bunch.

    Would be good to get http://henryranch.net/software/syndicate-press/ updated for the screenshots to reflect that 🙂

    Happy to send one over if it helps !

    Nik

    Plugin Author SP developer

    @hranchfundi

    ok, thanks for the feedback. I’ll get that screenshot updated. 🙂

    Hi, I’m getting – failed to get content and feed is not available – messages when I’m trying to get feeds of two sites.
    Can you please help me solve this issue…
    Site is: Smash Fascism

    feed URLs are : http://communalism.blogspot.com//feeds/posts/default?alt=rss
    and
    http://uaf.org.uk/?feed=rss2

    Plugin Author SP developer

    @hranchfundi

    Hi shabdsangharsh,

    For your first feed URL, when I open it in a browser, my browser is sent to the feedburner page and not the RSS news feed. Looking at the feedburner page, I found this RSS news link:
    http://feeds.feedburner.com/CommunalismWatch?format=xml

    Regarding the second link, I am wondering if that server is also doing a page-moved redirect which requires the client app to do a double request in order for the feed to be served. That host is being served off of TUCOWS hosting and I would not be surprised if they are doing the same thing as go-daddy is with the double request page-moved redirect trick.

    I am working on a solution to that which allows SP to still get the feed content from those types of hosts.

    Hello HranchFundi,

    Thanks you so much!
    I’m not technically very sound actually, so I couldn’t find the feed URL you provided. It’s working all right.

    But, I don’t understand page-moved redirect, so I would wait for Syndicate Press update when you’ve got the solution.

    Thanks again friend.

    Love this plugin and i appreciate your hard work! I am having problems with using a xml feed. I add the feed and have tried several feeds ending in .xml and they do not show up? If I add a feed that is an RSS feed then I have no problem. Here is a feed I have tried to get display…
    From this page I can select and feed such as ‘Incidents’
    http://ww2.tdot.state.tn.us/tsw/RSS.html
    the feed is http://ww2.tdot.state.tn.us/tsw/GeoRSS/TDOTIncidentGeoRSS.xml
    I added it to SP as
    TDOT|http://ww2.tdot.state.tn.us/tsw/GeoRSS/TDOTIncidentGeoRSS.xml
    put in my page as [sp# TDOT]

    I see in your examples you can use xml feeds correct?

    Please respond right away. i have tried to contact you on your website but there is no way to leave a comment or email. Thank you and Happy New Year!

Viewing 15 replies - 16 through 30 (of 42 total)
  • The topic ‘[Resolved] [Plugin: Syndicate Press] [Synidicate Press] Failed to get content’ is closed to new replies.