Syndicate Press
[resolved] Failed to get content (8 posts)

  1. Atlanta
    Posted 3 years ago #

    Hi I just updated the plugin and got this error message
    Failed to get content from 'https://news.google.com/news/search?hl=en&gl=us&q=Luxury+Fashion&output=rss'

    [sp# all]


  2. SP developer
    Plugin Author

    Posted 3 years ago #

    Thanks for your feedback! Syndicate Press does not currently support https protocol.

    You can access the feed via the non-secure http protocol with this URL: http://news.google.com/news/search?hl=en&gl=us&q=Luxury+Fashion&output=rss

    I'll add notification for this in the next release.

    Best Regards.

  3. Atlanta
    Posted 3 years ago #

    Thanks. I tried this non http url also and it didn't work


  4. SP developer
    Plugin Author

    Posted 3 years ago #

    Hi Atlanta,
    I reproduced the failure with the second feed http://www.google.com/alerts/feeds/04661213680440914985/336730953582831493.

    It does not work on my test system either. I'll take a look and see if we can work up a solution.

    Have a great day!

  5. Atlanta
    Posted 3 years ago #

    Thanks! I will wait for your reply!

  6. SP developer
    Plugin Author

    Posted 3 years ago #

    Hi Atlanta,
    I looked at the problematic google alert feed again today and it works.

    Here is a link showing it working in one of my test sites: http://codelikeapirateday.com/news/sp-test-google-fashion-feed/

    In the Feed URL tab I set the feed url as:

    On the page where I am showing the feed, I set the tag as:
    [sp# GoogleFashion]

    Some news feed servers will disable a client from receiving a feed if it is accessed too frequently within a given time period. Perhaps this is why we saw the feed not being returned a few weeks ago?

    Anyway, give it another try and let me know what happens.

    Have a great day!

  7. CivitanovaSC
    Posted 3 years ago #

    I have the same problem with these feeds:
    CronacheMaceratesi |http://feeds.feedburner.com/cronache_maceratesi
    Il Resto del Carlino |http://it.ilrestodelcarlino.feedsportal.com/c/33331/f/565701/index.rss
    Vivere Civitanova |http://feeds.feedburner.com/viverecivitanova
    Indiscreto |http://www.lindiscreto.it/index.php?format=feed&type=rss
    Corriere Adriatico |http://www.corriereadriatico.it/rss/cronache.xml

  8. SP developer
    Plugin Author

    Posted 3 years ago #

    Hi CivitanovaSC,
    I just tried out your feeds and they all worked except for this one:

    If you put that URL into the google chrome browser, chrome shows the feed has the following error: "error on line 41 at column 22: xmlParseEntityRef: no name." This is a problem with the feed formatting.

    Regarding the other feeds, they worked on my server. You might try clearing your input and output caches and then updating your settings again.

    Have you been able to connect to any feeds? If not, then your server might have php client sockets turned off. You can try my site feed here: http://henryranch.net/feed/ as a test.

    Another possibility is that the feed server can sometimes stop serving a client if the client IP hits the server too often. I believe that yahoo rss feeds do this. This is the reason why SP has a 3600 second (1 hour) timeout for a feed so that SP will only request a feed if the cache for that feed is older than an hour.

    If you are still having problems, you can send me a message via the address in the help tab of the SP plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Syndicate Press
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic