WordPress.org

Support

Support » Plugins and Hacks » SurveyMe » [Plugin: SurveyMe] Invalid Query after submission

[Plugin: SurveyMe] Invalid Query after submission

  • I’m receiving this error after trying to submit:

    Invalid query: Incorrect column name '1. Does your POS system provide control of food leaving the ' Whole query: ALTER TABLEwp_surveyme_questionnaireADD COLUMN1. Does your POS system provide control of food leaving the text

    I originally used a default survey and then made a copy and tried that one as well. The result was still the same. If I remove “1.” it will then throw an error in another question but with a different query.

    http://wordpress.org/extend/plugins/wp-survey/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author DCoda

    @dcoda

    Are you using the current version. The probable cause for this error should have been fixed, but perhaps not.
    It may be that the question is too long, as it will be used for the column name in the table. I should be truncated to the required length but maybe not enough.

    Anyway, the quick fix would be to shorten the question in the ‘Concise Prompt’ and if required put something in the ‘Expanded Prompt’ to compensate.

    Yes, I am currently using the latest version. If you can point me to where I can increase the length, I can look into the file. I looked in the db, and it seems the tables aren’t created until the survey itself is.

    For the time being, I will search for the files to see if I can increase the length somehow.

    Keep me posted, thanks

    Plugin Author DCoda

    @dcoda

    You cannot change the length. you need to shorten the concise prompt and use the expanded prompt.

    Hi, sorry for the late response. I got the chance to play around with it again. Unfortunately, The questions I’m using are somewhat long and using both and/or the expanded prompt will throw the error.

    Is there a possible solution to this?

    Plugin Author DCoda

    @dcoda

    are there single or double quotes in the question, or any special characters?

    Some will contain quotes, double quotes & and /

    Plugin Author DCoda

    @dcoda

    These should be accounted for, but I will double check to see if the problem has snuck back in with the upgrades.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: SurveyMe] Invalid Query after submission’ is closed to new replies.
Skip to toolbar