Support » Plugin: Supra CSV » [Plugin: Supra CSV] Possible error found in code

  • Resolved WebsThatRock


    In Supra CSV Importer version 2.7.9 and WordPress version 3.4.2 after I deleted and uploaded about the 4th time I get the error message, “transport error – could not open socketProblem Ingesting . . .”

    I am also using the plugins Type and Views to handle the csv file imported using Supra.

    Below is a support chat with my hosting company and what he believes to be the problem.

    Michael Rock:I tried googling the error message and the only thing that came up was ‘a problem with the hosting’. Which I didn’t believe because it worked a few times before.
    Jesse P.:I am now at the form that you specify in your instructions to do the following:

    “fill out the forms to match”

    What should I do next.
    Michael Rock:There should be drop down boxes to match up with text. You can try ingesting the file without doing this you will probably get the same error.
    Jesse P.:Alright. I shall not make any selections in any of the drop down boxes. There are a lot of options and I wasn’t sure if I should do anything next.
    Jesse P.:I have received the error that you are speaking of. I am going to investigate more deeply now.
    Michael Rock:Thank you. I hope you can come up with a solution.
    Jesse P.:I will do my best! I can’t guarantee anything, as this is a script related issue and it might be an error with the plugin itself, but we’ll see what we can find.
    Michael Rock:When it happened at I even uninstalled the plugin and reinstalled it then started from scratch and it still didn’t work. The next thing I was going to do was look at phpmyadmin and see if I could somehow delete the files there and try starting from scratch again.
    Jesse P.:If you don’t mind me asking, what would be deleted from phpMyAdmin?
    Michael Rock:After uninstalling the plugin again I was going to do a search for anything ‘left behind’ since when I uninstalled it the last time some values were ‘remembered’ telling me that it wasn’t a clean uninstall. Reinstalling the whole wordpress site seemed to be to much trouble and if I reinstalled wordpress from a backup I probably would get the same problems again.
    Michael Rock:Another clue for you was when this happened at I tried deleting the file and uploading and ingesting the old file that worked in the past to test things out, but the error came back for the old file that used to work also.
    Jesse P.:That’s understandable, and at the moment, the only thing I’m able to see that this isn’t a problem with the server itself, but either with the plugin or with the csv file that you’re attempting to upload.
    Michael Rock:I had tried uploading a csv file that worked in the past but it won’t work anymore over at
    Jesse P.:That’s helpful to know. We’re seeing that it’s actually something to with with the file at /home/wptrails/public_html/Delaware/wp-content/plugins/supra-csv-parser/classes/ in some form or fashion. I’m trying to see if I can glean any further details.
    Jesse P.:It seems to be a coding error of some sort with this file that is causing the problem. It would make sense that the plugin is failing to upload old files that worked since it appears that the plugin itself is not working correctly.
    Michael Rock:what do you see there?
    Jesse P.:We see the following code: 102 foreach($args[‘custom_fields’] as $k=>$v) {

    Unfortunately, HostGator does not employ developers or experienced coders, and since we did not develop the plugin itself, we wouldn’t be able to resolve this sort of error for you. We advise that you contact the developer of the plugins with the errors that you are receiving and seek advise from them on how best to proceed.
    Michael Rock:What should I tell the developers exactly? On the file wp-content/plugins/supra-csv-parser/classes/CsvLib.php there appears to be a code error at 102 foreach($args[‘custom_fields’] as $k=>$v) { ???
    Michael Rock:How did you know that was the line causing this problem?
    Jesse P.:I would tell them the same things that you have explained to us. How to replicate the problem, what errors that you are receiving, and what troubleshooting steps you have taken so far. They are all very helpful in getting to a conclusion on what the problem is and what is causing it. The problem in HostGator’s case is that this actually involves the coding of the plugin itself, which is not something support since it is a third party product.
    Jesse P.:We know that it is that line due to the errors that we received when we replicated the problem:

    Warning: Invalid argument supplied for foreach() in /home/wptrails/public_html/Delaware/wp-content/plugins/supra-csv-parser/classes/RemotePost.php on line 102
    transport error – could not open socketProblem Ingesting untitled
    Michael Rock:Ok. Thanks for telling me that it isn’t a server problem and thank you for pointing out my potential disaster with That would have been bad.
    Jesse P.:You’re very welcome! 😀 I was very glad to help you with that. I do apologize that I have no precise fixes regarding this error you are receiving with your site, however, I would like to paste the specific errors that you are getting. It is basically a repetition of the following two errors:

    Warning: Invalid argument supplied for foreach() in /home/wptrails/public_html/Delaware/wp-content/plugins/supra-csv-parser/classes/CsvLib.php on line 194

    Warning: Invalid argument supplied for foreach() in /home/wptrails/public_html/Delaware/wp-content/plugins/supra-csv-parser/classes/RemotePost.php on line 102
    transport error – could not open socketProblem Ingesting untitled
    Michael Rock:Okay, I will notify the developer.
    Jesse P.:Very well. Did you have any more questions for me, or did you need any more clarification?
    Michael Rock:That should be enough for him to go on. Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Joseph Persie


    Sadly that has nothing to do with the issue but it does not suprise me how farfetched the ‘solution’ was considering it was hosting support. Its has to do with php’s fastcgi settings. This issue was also experience by another user and was solved:

    Incase anyone else has this issue and uses plesk panel. There is an issue if you are running php as FastCGI. The session created by the plugin fails to save due to permissions for the default session save path. The solution is creating a custom path to save sessions for the domain and manually setting the owner/permissions for this directory.

    Plugin Author Joseph Persie


    Additionally may be related to: Sounds like port 111 (RPC) is disabled on your host. Have you tried contacting them?

    Also try it on another server. The issue it derived the the xmlrpc utilization which involves a specific protocol that must be properly configured

    Okay, I use cpanel for my host not plesk so do I still find out if port 111 is disabled on the host? What should I ask my hosting provider?

    I just found out that FastCGI is not used to run the php and that port 111 is not opened because it appears it is commonly used for RPC attacks. One question tech support asked was does it need to be opened for incoming or outgoing.

    I just had the port opened and I was able to injest the file fine this time.

    Plugin Author Joseph Persie


    great thanks for the thread

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Supra CSV] Possible error found in code’ is closed to new replies.