Support » Plugin: Supra CSV » [Plugin: Supra CSV Importer] Problem ingesting file

  • Resolved JasonBC

    (@jasonbc)


    Using ver. 2.5.1- I’m not sure why my file has a problem ingesting, I get this message for all 475 records:
    Sorry, one of the given taxonomies is not supported by the post type.Problem Ingesting

    My file is pretty straighforward with fields like: property,city, country, website, featured, active.
    It discovers my post type just fine. City and country are preset as category type taxonomies. I checked on “parse complex categories”. Those taxonomies are not detected with the post meta suggestions so that’s probably part of the problem, but I don’t know where I’m going wrong.

    http://wordpress.org/extend/plugins/supra-csv-parser/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Joseph Persie

    (@zmijevik)

    turn on debug ingestion in the configuration tab and paste the output here make sure its only for the first three posts

    Plugin Author Joseph Persie

    (@zmijevik)

    In the newest version i have provided issue reporting which sends me an email of the debug output when you check the issue reporting checkbox in the configuration tab. the debug output will notify whether or not the issue has been successfully reported

    Plugin Author Joseph Persie

    (@zmijevik)

    this problem has been fixed in the latest version, thanks for beta testing

    I’m trying again with your latest update. It’s still not seeing my taxonomies in the detection stage or during ingestion in the “custom terms” section. The mapping preset on the righthand side of the ingestion screen doesn’t show any choices even after I created a preset. I created my custom post type with the “Types” plugin.

    Perhaps if I had an example of how the taxonomies should be setup, then I’d understand the process better. It seems like the instructions for this were left incomplete. It takes a very long time >30 minutes to inject a 480 line file, is that normal?

    Plugin Author Joseph Persie

    (@zmijevik)

    quick google search: “d fields lets you do things that no other custom-fields plugin can do. … Types custom fields use the standard WordPress post-meta”

    because the types plugin chose to deviate from the wordpress convention this plugin is incompatible with your custom post type records.

    Plugin Author Joseph Persie

    (@zmijevik)

    create a new post of the custom post type and provide all possible values, this will give you suggested post meta values to conform to.

    Plugin Author Joseph Persie

    (@zmijevik)

    if this is the same plugin than it should support postmeta convention:
    http://wordpress.org/extend/plugins/types/

    Yeah, that’s the plugin. It’s been doing the ingestion process for over an hour. It didn’t take this long before.

    Plugin Author Joseph Persie

    (@zmijevik)

    provide the csv file so i can test it

    Thx for oppty to post on the support forum.

    For me, the plugin isn’t able to complete the ingestion process. (The program keeps “thinking”). I suspect this is because I’ve uploaded a file that is somehow broken. Here are the errors that I see when I preview the uploaded file:

    fgetcsv() expects at most 4 parameters, 5 given in /home/kaker/public_html/gearlisted.com/wp-content/plugins/supra-csv-parser/classes/UploadCsv.php on line 122

    Warning: implode() [function.implode]: Invalid arguments passed in /home/kaker/public_html/gearlisted.com/wp-content/plugins/supra-csv-parser/classes/UploadCsv.php on line 125

    Warning: fgetcsv() expects at most 4 parameters, 5 given in /home/kaker/public_html/gearlisted.com/wp-content/plugins/supra-csv-parser/classes/UploadCsv.php on line 122

    Plugin Author Joseph Persie

    (@zmijevik)

    what do you have for csv settings at the bottom of the configuration page?

    delimiter:,
    enclosure:”
    escape:\

    These are the default settings I believe. Maybe this should be tab delimited??

    Tx.

    Plugin Author Joseph Persie

    (@zmijevik)

    update to php 5.3 this should fix the problem

    Plugin Author Joseph Persie

    (@zmijevik)

    try version 2.7.2 it prevents from having to upgrade php

    I tried this. Initially, I was getting another error, which suggested that I needed to change my WordPress XML Settings (Writing Settings). I’m still having some problems with the fields, but I suspect that I can resolve that by playing with the mapping, etc.

    Thanks for the tip!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: Supra CSV Importer] Problem ingesting file’ is closed to new replies.