Support » Plugin: Subscribe2 » [Plugin: Subscribe2] Subscribe to Updates Fatal error: Class 'WP_User_Search' not found i

  • Fatal error: Class ‘WP_User_Search’ not found in /home/a……/public_html/wp-content/plugins/subscribe2/subscribe2.php on line 1499

    This message is produced when people are attempting to subscribe to my site. Please advise.

Viewing 8 replies - 1 through 8 (of 8 total)
  • @atlohi,

    Versions please – what WordPress and Subscribe2 are you using?

    Sorry. I just upgraded to WordPress 3.1 and I’m using Subscribe2 version 6.2 Based on some other posts, I switched the plugin to look to WP_User_Search in deprecated.php and that seems to have solved the problem for the time being.

    @atlohi,

    Thanks for the details, it seems that WP_User_Search is replaced by WP_User_Query in WordPress 3.1.

    I’ll work on updating my code to make it 3.1 compliant. In the meantime your fix should work fine.

    Thanks very much!

    atlohi, if you could, where did you change the plugin? Where is the deprecated.php file? I don’t see it in the subscribe2 folder. This is set for all plug-ins somewhere?

    I happened to download the plug-in today and it’s unfortunate that WP 3.1 has caused this problem. I’m impatient!

    Thanks.

    Do a search for WP_User_Search and change the code to point to deprecated.php. There are several instances in the plugin. The revised lines will look like this:

    if ( !class_exists(WP_User_Search) ) {
    require(ABSPATH . ‘wp-admin/includes/deprecated.php’);

    @johnakeith,

    I’ve also pushed these changes into the development version of the plugin if you are uncomfortable editing code and would rather just download.

    @mattyrob thanks for the updated files. I have uploaded them and all is working again in 3.1.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Subscribe2] Subscribe to Updates Fatal error: Class 'WP_User_Search' not found i’ is closed to new replies.