WordPress.org

Forums

Subscribe2
Subscribe box not showing up (9 posts)

  1. Lisa Hogan
    Member
    Posted 3 years ago #

    Hi,
    I jjust created a new blog post and hit the S2 button to add my subscribe3 subscription box to the bottom of my post. The code shows up in my HTML but there is no box showing up in my posts. It was working fine. Any way to fix this? Not sure what I did.
    http://www.lisascreativedesigns.com/lisascottageblog/2012/02/a-kitchen-display-cabinet-this-one-is-for-the-birds/

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Posted 3 years ago #

    @Lisa,

    Did you log out? If not you may have seen some text instead of the form saying "To manage your Subscription, visit your profile".

  3. Lisa Hogan
    Member
    Posted 3 years ago #

    No I did not Log Out. I don't see any text at all at the bottom of the post where the subscribe box should be. I can't figure it out.

  4. mattyrob
    Member
    Posted 3 years ago #

    @Lisa,

    What version of Subscribe2 and WordPress are you using?

    When you say the 'code' shows up in the HTML window - is it the shortcode ([subscribe2]) or is it the token with arrowed brackets around it?

    Are you running other plugins that filter your content? Does the token/shortcode work elsewhere? Like pages for example?

    EDIT: In fact the placeholder code is present in your page - are you using any plugins that alter the behaviour of the RichText editor?

  5. Lisa Hogan
    Member
    Posted 3 years ago #

    I am using the latest version of WordPress. I am using Subscribe2 version 7.2. It was working just fine last week but now it will not. I am thinking perhaps its another pplugin that I am using but deactivated any new plugins and still nothing. I just added the S2 Subscription box to a page and it worked.

    This is the HTML code I see in the post when I look at the HTML View.
    <img class="mceSubscribe2" src="http://www.lisascreativedesigns.com/lisascottageblog/wp-content/plugins/subscribe2/tinymce3/../include/spacer.gif" alt="" />
    Still Not showing up. I am thinking its something stupid but I am still scratching my head on this.
    I don't think I am using any plugins that alter the Rich Text Editor.

  6. mattyrob
    Member
    Posted 3 years ago #

    @Lisa,

    That code you are seeing is not the correct code for the frontend of the site, it's the image placeholder for the TinyMCE editor. In the HTML view take that out and replace it with [subscribe2] (including the []).

  7. Lisa Hogan
    Member
    Posted 3 years ago #

    Ok, I deleted it and added the [subscribe2] Now it works. My question is this, why is it placing image placecard and not the subscription box in the post when I hit The S2 in the editor? I just started using it a few posts ago and it worked great. Did I do something wrong?

  8. mattyrob
    Member
    Posted 3 years ago #

    @Lisa,

    I have no idea what would have caused that to happen. I have been trying to improve the editor code recently to correctly replace the shortcode even if it includes any optional parameter. Maybe it's something in that new code that I've missed but it seemed to work well in my tests.

    Until I know exact steps to reproduce what you saw it's difficult to code a fix. Does this happen every time you use the button in the editor?

  9. Lisa Hogan
    Member
    Posted 3 years ago #

    I just tried doing a test post and the S2 button worked. I have no idea why it did not work before. Thanks so much for the shortcode. It worked just fine. If the S2 button quits on me again I will just add the shortcode.

    Thanks a bunch :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags