Support » Plugin: Subscribe2 » [Plugin: Subscribe2] Not sending notifications for new posts

Viewing 15 replies - 1 through 15 (of 17 total)
  • @axterx,

    If you want to revert to 7.1 if you are certain that was working you can download it from here.

    Have a look at recent posts on here though, especially if you are hosted on GoDaddy.

    Thank you. I do not have hosting on GoDaddy …
    I read in the FAQ that Subscribe2 need WP-Cron to notify future posts. I never had WP-Cron and everything worked well with future posts, has anything changed?


    That must have been an old entry, wp-cron was incorporated into the WordPress core a few years ago now. The current FAQ covers some cron issues under the question “My Digest emails fail to send, why?”.

    I am hosted on GoDaddy and my Subscribe2 has stopped working. What’s the connection? GoDaddy’s not being much help.


    Connection is discussed here.

    As you say, GoDaddy’s not being much help.

    OK, I have now gone through the WordPress Forum and GoDaddy Support Forum
    and have done the following:

    1) Installed the *WP-Mail-SMTP *as per the WordPress forum;

    2) set the SMPT host to as per the GoDaddy
    support forum on the Subscribe2 plugin and this very problem

    Then tried emailing from the blog and this is what we got


    Message failed! Check your settings and check with your hosting provider
    SMTP Error: The following SMTP Error: Data not
    accepted. (followed by the
    full list of subscriber email addresses…)

    Of course, GoDaddy just keeps telling me that they can see emails going through.

    What’s my next step?


    Can you successfully send test message from the SMTP mailer plugin?

    It seems that another GoDaddy restriction is to limit each email to a maximum of 100 recipients, in Subscribe2->Settings make sure to set the number of recipients to a number less than a 100 and not 0 if you have more than 100 subscribers.

    Yes, I can send a test message from the SMTP mailer plugin.

    My understanding is that GoDaddy’s limit is 1000 per day. Has that really changed to 100?

    I also did the update and stopped being sent new email notifications, and now I received an email with an error message.

    554 too many recipients (# 5.5.3)

    Could I help?


    As I understand it you have 250 emails per day on shared hosting and a 1,000 per day on VPS.

    The limit of 100 is recipients per email which is different. Basically, if you are on shared you cannot send 1 email to all 250 of your allowed recipients. Instead you must send a minimum of 3 emails to 100, then 100 then 50 recipients.


    Ah-ha – a meaningful error message. That would read to me like you are sending to too many people in one email message.

    In Subscribe2->Settings limit the number of email recipients per email by setting the “Number of Recipients per email” to a low number – try 30 as a start and see if that helps.

    OK, I asked GoDaddy about the limit on number of emails and here is there response:

    It appears that you are inquiring about SMTP Relays and our hosting plans. The current limit for our hosting plans is 1,000 SMTP Relays per day. This limit is generally reset when the servers are restarted (about 1:00 AM, AZ time). There is no ETA for when this limit will be increased in the future.

    Please let us know if we can assist you in any other way.


    That fine but you still can’t send 1 email to 1,000 recipients based on the 100 recipient limit. It would have to be 10 emails to 100 recipients for each email.


    I think what I’m not understanding is where the 100 recipients per email limit is coming from? GoDaddy, Subscribe2 or the WP-SMTP plugin?


    -one more response from GoDaddy

    There is no limit to the number of email recipients. However, each email recipient will count as one relay. For example, having the message sent to ten recipients will count as ten relays

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Subscribe2] Not sending notifications for new posts’ is closed to new replies.