Support » Plugin: Subscribe2 » [Plugin: Subscribe2] Message failed error, but Send Email Preview works

  • Hi, I am trying to send a single test email to myself (I’m the only registered user) and it gives me the error: “Message failed! Check your settings and check with your hosting provider”

    However, when I choose Send Email Preview from the Settings page, it emails a test message to me no problem.

    I am using Hostgator as a provider, but I have not checked the logs with my provider because I was able to successfully send the Preview email, so I am guessing my provider is not the problem?

    Any ideas of what to test next?

    Thanks,
    Sam

    http://wordpress.org/extend/plugins/subscribe2/

Viewing 3 replies - 1 through 3 (of 3 total)
  • @sgridley,

    Subscribe2->Settings, change the number of recipients to 1 and make sure that the sender of the email is on-domain. Look through previous forum posts for more on these if you don’t understand, it’s been covered many times before.

    If that doesn’t work then speak to your hosting provider.

    MattyRob, it is working for me after all. After disabling a bunch of plugins and it still not working. I tried something different.

    For the Preview email, I added one word of content and viola! It worked!

    I guess when you try the test Preview or Send with no content, it gives you a Failed message. I bet a lot of people get tripped up on this too.

    Thanks for your help, I’m heading over to get the html license now that I know it works!

    Sam

    @sgridley,

    I’m glad you got it working – you’ve tripped over one of the fail safes I guess – not much point the plugin sending your readers empty emails so it’s coded to bail if the content is empty.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Subscribe2] Message failed error, but Send Email Preview works’ is closed to new replies.