Support » Plugin: Subscribe2 » [Plugin: Subscribe2] is_blog_user() deprecated

  • Resolved hallcp

    (@hallcp)


    Version 8.5 of this plugin gives me warnings of “is_blog_user() is deprecated, use is_user_member_of_blog()”.

    I found references to “is_blog_user()” in these two files:

    line 18: classes/class-s2_multisite.php

    line 15: classes/class-s2-core.php

    This is a “network” install.

    http://wordpress.org/extend/plugins/subscribe2/

Viewing 2 replies - 1 through 2 (of 2 total)
  • @hallcp,

    Thanks for this, that function is only used on multisite installs so I don’t see it. I’ll aim to get a fix for that into the next version. I’ll also post here when I’ve fixed it in the development code if you want to test it.

    @hallcp,

    I’ve just checked in some changes that should hopefully fix this. Give the development code a try and let me know if it works and those messages clear up.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Subscribe2] is_blog_user() deprecated’ is closed to new replies.