WordPress.org

Forums

Subscribe2
[resolved] How to change default email? (12 posts)

  1. keith48
    Member
    Posted 2 years ago #

    At the top of my settings page, I have this message: "You appear to be sending notifications from an email address from a different domain name to your blog, this may result in failed emails"

    I recently moved my blog from one web host to another, and I have looked through every page of the plugin and widget and see no place to change the email address. Help please!

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Posted 2 years ago #

    @keith48,

    If you already have an existing email that is on the same domain as your blog (so if you blog is http://www.example.con then something like admin@example.com) then use this as the email address of an administrator level user in WordPress by either creating a new account user or changing the email on an existing account.

    The go to the Subscribe2->Settings menu and choose that user name from the drop down list where is says "Send email notifications from:".

  3. jlapac@gmail.com
    Member
    Posted 2 years ago #

    The instructions above do not work. There is no list of users or a drop down list that I can see. Can you post some pictures of the process?
    Thanks.
    Jaye

  4. mattyrob
    Member
    Posted 2 years ago #

    @Jaye,

    It's the bottom screen shot on this page:
    http://wordpress.org/extend/plugins/subscribe2/screenshots/

  5. jlapac@gmail.com
    Member
    Posted 2 years ago #

    Thanks, but that doesn't help me actually change the email address; it only helps me change where the email comes from. When I set up S2, I did not have an email with the same domain. Now I do and I would like to change the actual email.

    thank you,
    Jaye

  6. mattyrob
    Member
    Posted 2 years ago #

    @Jaye,

    Now you have an on-domain email address, use that email in an existing WordPress user or create a new account at Users->Add New.

    Then use this account as the sender.

  7. jlapac@gmail.com
    Member
    Posted 2 years ago #

    Perfect! Thanks for your patience in answering my questions. It worked like a charm!

  8. mattyrob
    Member
    Posted 2 years ago #

    @Jaye,

    Excellent news, it's easy to over look the obvious sometimes. I'm glad it worked.

  9. fernando.azevedo@gmail.com
    Member
    Posted 1 year ago #

    I am still sending emails from the email address I dont want!
    I set another admin user to be the one to send emails but I still receive the emails from me!
    Can you help me?

  10. mattyrob
    Member
    Posted 1 year ago #

    @Fernando,

    Tell me the steps you followed when trying to change the sending email address. Also check you are not using another plugin that sets the email address, Configure SMTP for example.

  11. fernando.azevedo@gmail.com
    Member
    Posted 1 year ago #

    i erased the user that is sending the email.
    Than I went to the settings of the Subscribe2 and changed to another user.
    But it still sends email from the old one!!! How bizarre is that????

  12. mattyrob
    Member
    Posted 1 year ago #

    @Fernando,

    I was hoping for a little more detail in the steps you followed, where did you delete the user? Did you check for duplicates? Have you checked for other plugins affecting the wp_mail() function? Where in the Subscribe2 settings did you change the sender? Was it a user name or the name of the blog you picked?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Subscribe2
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic