WordPress.org

Forums

Subscribe2
[resolved] Error notice in latest version! (42 posts)

  1. M.A. IMRAN
    Member
    Posted 2 years ago #

    After updating to subscribe2 latest version, it showing this notice:
    "You appear to be sending notifications from an email address from a different domain name to your blog, this may result in failed emails."

    and emails are not sending! whats the problem?

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Posted 2 years ago #

    @imran2w,

    I have so many people doing exactly what you are doing! That's why I've implemented this error message. I think it's pretty self explanatory, you are trying to use an email address to send your notifications that is not on-domain with your blog; the message is not stopping sending but it's telling you WHY your emails are not sending.

    If your blog is http://www.example.com you need to use an address something like admin@example.com to send the emails.

    You may need to create this email address with the help of your hosting provider, you then need to add this email address to a user account with admin level privileges within WordPress and select this as the Sender in Subscribe2->Settings.

  3. ahicks
    Member
    Posted 2 years ago #

    I have an email address from the domain and it still keeps showing the message. Not sure how to get it right?

  4. mattyrob
    Member
    Posted 2 years ago #

    @ahicks,

    Has that email address been entered as the email address for an admin level user on your blog (Users->All User)?

    Have you selected that same user account as the preferred sender of Subscribe2 email in Subscribe2->Settings where it says "Send Email From:" under the Notification Settings heading?

  5. vividself
    Member
    Posted 2 years ago #

    This is not right. The subscriber should see that emails are coming from a legit company email, not admin@blogname.com email. Some companies have a separate domain name for their blogs. The settings was better when I did not update. How can this be reverted back to its previous version?

  6. mattyrob
    Member
    Posted 2 years ago #

    @vividself,

    Look for this file on your WordPress install:
    wp-content/plugins/subscirbe2/admin/settings.php

    Edit it and at the top you'll see these lines:

    $sender = $this->get_userdata($this->subscribe2_options['sender']);
    list($user, $domain) = explode('@', $sender->user_email, 2);
    if ( !strstr($_SERVER['SERVER_NAME'], $domain) ) {
    	echo "<div id=\"message\" class=\"error\"><p><strong>" . __('You appear to be sending notifications from an email address from a different domain name to your blog, this may result in failed emails', 'subscribe2') . "</strong></p></div>";
    }

    Comment them out.

  7. Any chance this message could be added via hook (so that I can remove it via hook)? :)

  8. mattyrob
    Member
    Posted 2 years ago #

    @MadtownLems,

    I'll see, may be possible at some point. ;)

  9. Or maybe give it a unique class/id?

    <div id="s2-email-warning" class="error">Oh heads up yo, you might have email trouble!</div>

  10. mattyrob
    Member
    Posted 2 years ago #

    @MadtownLems,

    You are quite right there of course. I'm re-using the same ID for 2 messages when CSS IDs should be unique for validation reasons. I'll get that fixed for 8.5 and you can use CSS to hide it if you like.

  11. gabyu
    Member
    Posted 2 years ago #

    Thanks for your support. I found the issue on this page and it solved my problem. thanks.

  12. Loggy
    Member
    Posted 2 years ago #

    I'm not too sure this is a good idea anyway.

    A blog with just one user (hopefully not called admin) may well need an email address that is specifically not from the domain. That way, if the domain falls over (eg expires or there is a registration/nameserver problem) the admin can be warned.

    Or if you have multiple users posting, they may not have or want to have me@blogname.com addresses.

    A better (and I think simpler) solution would be to have a SENDFROM parameter in the setup that the user can alter. That way, the name server rDNS and spf records should be satisfied. And send from could comrise USERNAME and BLOG_DOMAIN.

    I see there is already EMAIL but that is just the default.

  13. mattyrob
    Member
    Posted 2 years ago #

    @Loggy,

    A lot of hosting providers are now implementing policies that demand that the 'sending' email address actually exists. Creating a single newsletter email address and a single account with that email address is really not that difficult in my opinion and solves all of the issues you raise above with the addition that the email address is probably also in existence.

    Of course not of this would be necessary if it were not for spam anyway but there's nothing we can do about that.

  14. bleepinjeep
    Member
    Posted 2 years ago #

    "you then need to add this email address to a user account with admin level privileges within WordPress"

    Can you please explain where to go to do this? Ive tried but its still not working so maybe I am not doing something right...

  15. bleepinjeep
    Member
    Posted 2 years ago #

    Ahh, I found it. Its under Users - Your Profile.

    I hadn't messed with that since starting the blog and forgot it was there.

  16. phjohan
    Member
    Posted 2 years ago #

    Surprisingly, I am still having this problem, which is not sending emails.
    True, my user-admin email address is different than the settings email address. The settings email address is used for admin purposes while the user address is for comments to posts and pages. Since many individuals leave messages, then there exists many emails. Within this week, I released a page and a post and none were sent to even myself or others. This is very frustrating not being able to communicate to members. Specific instructions are welcome and yes I have reviewed the manual.

  17. mattyrob
    Member
    Posted 2 years ago #

    @phjohan,

    Individuals leaving messages and as such their emails should have no bearing on this at all.

    I'll try to give you some simple steps to follow based on the following assumptions.
    1) You have an admin level user account on your blog
    2) You have an email address on-domain with your blog (so if your site is http://www.example.com you have an address like info@example.com that you want to use for sending the notifications.

    So, now you have these things, log into your WordPress site and go to Users -> Add New. Create a new user account using the email and make sure you set the role as Administrator.

    Once that is done go to Subscribe2->Settings and where it says "Send Email From:" and there is a drop down list, select the user name of the account you just created.

    Emails will now be sent from this account and hopefully pass your hosting providers anti-spam policies.

  18. phjohan
    Member
    Posted 2 years ago #

    1. You have an admin level user account on your blog - Yes
    2. You have an email address on-domain with your blog - No. The email address on domain is in the settings area. Changing the email address in the user area to the domain will create many emails from blogs and posts. The user name is called admin and is not on the drop down list. Thanks for the quick response.

  19. phjohan
    Member
    Posted 2 years ago #

    "Once that is done go to Subscribe2->Settings and where it says "Send Email From:" and there is a drop down list, select the user name of the account you just created." - My choices are post author, the website name, or my real name. My preferred is the website name.

  20. phjohan
    Member
    Posted 2 years ago #

    Of course, I have over 10,000 emails on the list that are both valid or invalid and growing. That is why I selected unlimited as a choice. Thus, looking for answers since more work is proceeding. Thanks is advance for the advice.

  21. mattyrob
    Member
    Posted 2 years ago #

    @phjohan,

    Why don't you create a new on-domain email address then to use for sending the notifications?

  22. phjohan
    Member
    Posted 2 years ago #

    @mattyrob,

    Thanks for the suggestion and will give this a try.

  23. phjohan
    Member
    Posted 2 years ago #

    @Mattyrob,

    "Why don't you create a new on-domain email address then to use for sending the notifications? " - Does not work and must be doing something wrong or confused. Clarifications:
    A new domain email address was created on my host ipage
    A new user was created with admin rights
    Logged into the Dashboard using new user
    Created a preview test to one person - OK
    Created a send email to many including myself and was not received, however states message sent. Thank you in advance. I think this problem requires some dissecting. Many = 10,000+

  24. mattyrob
    Member
    Posted 2 years ago #

    @phjohan,

    If you've created that email and updated the sender correctly then I expect that the next part of your issues is that you have so many subscribers. You will certainly be exceeding the send limit with that number of subscribers on any free or paid hosting service.

    You need to remove the invalid emails and throttle the mail sending. Alternatively, if this is a business you need to consider paying for a proper and reliable email marketing solution.

  25. Tibor Paulsch
    Member
    Posted 2 years ago #

    I am having this problem too; Subscribe2 has always worked with the setting "Post author" as the sender of the mail (even though author's mail adress is from a different domain, since the website is on an intranet domain). Apparently after a certain update it just stopped working. My question is what has been changed so it stopped working.

    When sending a mail from the "send an email to subscribers" panel, I get the following message:

    "Could not instantiate mail function."

    Any help is much appreciated.

  26. mattyrob
    Member
    Posted 2 years ago #

    @Tibor,

    The code has not been changed - this is a warning message giving one of the main reasons why emails fail to send.

    If your WordPress is an intranet site you need to speak with your network admins and whoever set up the server to find out why the mail function cannot be instantiated. Sometimes it has been disabled, sometimes it needs an authenticated log in.

  27. Tibor Paulsch
    Member
    Posted 2 years ago #

    Thx for the quick notice!

    Strange thing is that I get new post notifications in my admin mailbox, so apparently it is working, but only to the admin's mail adres.

  28. mattyrob
    Member
    Posted 2 years ago #

    @Tibor,

    Try settings the number of recipients per email to 1 in the settings page. This will avoid use of the BCC header in the notification emails. It may be that this header is being stripped out and ignored on your server. That might explain why you get the email but nobody else does.

  29. Tibor Paulsch
    Member
    Posted 2 years ago #

    @mattyrob, that did it.

    Thanks again for the lightning fast reply! You've made my day!

  30. finklez
    Member
    Posted 2 years ago #

    Hi mattyrob, i could be wrong but i think there is a prob with this warning

    in the 'Send Email From' dropdown, there are 3 'types' of choices:
    - post author
    - user1/2/3..
    - blog name

    i started by using the blog name, so i would assume it checks the email settings under 'Settings -> General -> E-mail Address'. I tried setting this email to use the same as the domain, but i still get this warning,
    and since i hate to see error msgs, i tried to use your suggestion, to create a user with the domain email, which 'solved' the prob (eliminated the warning), but the issue is like this:

    the outgoing mail server has the hosting domain name, and is different from the incoming address which has the blog domain name..

    here's a short version of the email source:

    Delivered-To: my_email@gmail.com
    Return-Path: <name@253717.hostname.net>
    Received: from 253717.hostname.net ([xxx.xxx.xxx.xx])
    To: my_email@gmail.com
    Subject: =xxxx=
    From: blogname <name@mydomain.com>
    Reply-To: blogname <name@mydomain.com>

    so you can see that the sender (hostname mail server) is diff from the 'from/reply-to' which uses the domain name.
    when i gave the new user the hosting email (outgoing), i still got the warning, and only when i used the domain (incoming) email, the warning disappeared..

    i'm no email expert, but not sure if this makes much sense? is it ok to have the 'From' diff from the 'Receieved: from'?

    also note that although i get this warning, the emails are working fine..

    also when using the 'post author' choice, it might not make sense for many blogs as mostly users use their own email address and not the domain's? altho having this option won't hurt..

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Subscribe2
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.