Support » Plugin: Subscribe2 » [Plugin: Subscribe2] Emails not sending

  • Resolved joshukraine


    Hi there,

    I’ve used Subscribe2 for a long time on several blogs and have been very pleased with it.

    Unfortunately, it has suddenly stopped working for us. There is no apparent error, but emails do not get sent. This includes post notifications as well as the manual emails using the “Send email” feature. Preview emails do not send either.

    I’ve searched around for similar issues by other users but so far have not found a resolution. Here’s what I’ve done so far:

    1. Noticed the warning about off-domain emails. That was never a problem before, but just in case I switched to an on-domain email. No improvement.
    2. At the suggestion of another forum post, I deactivated all other plugins except Subscribe2. No change.
    3. I have another plugin which I use as a contact form, and emails from this form send fine. Instantaneously in fact. This leads me to believe that the problem is not with my host. Nonetheless, I have notified them of my problem and am waiting for a response.
    4. I’ve read the Subscribe2 ReadMe file and played around with various settings, but still can’t find the problem.

    In short, I get no particular error, but emails just don’t send. As I mentioned above, I use Subscribe2 on several blogs. They all stopped working at the same time.

    As far as I know, everything is up to date (WP and Subscribe2)

    Any assistance would be greatly appreciated. Thank you!


Viewing 15 replies - 1 through 15 (of 16 total)
  • @josh,

    You have covered most of the bases already.

    One thing you haven’t mentioned is your theme. Have you tried reverting to a core theme as there are sometimes theme conflicts.

    The only other suggestion I have is to install either WP Mail Log or Email Log so you can see if the emails are being passed to the wp_mail() function. This would exclude WordPress or Subscribe2 (or a conflict) as the cause and narrow the search to further upstream – like the sendmail binary on the server.


    Thanks for the input. I am using a child theme bases on the WordPress’s standard TwentyEleven theme. Although this has never caused any issues, I did try switching back to the vanilla TwentyEleven. No effect.

    Also, I realized that since the problem started I had not attempted to subscribe any new users. When I did this, I was able to subscribe a new email address without a problem and promptly received a notification via email. So the plugin can send email, it’s just not sending it when a new post is published OR when any preview email function is invoked. Basically, the new subscriber notification (and subsequent confirmation) are the only operations with which I have been successful at generating emails using the Subscribe2 plugin.

    I’ll go ahead and install one or both of the mail plugins you suggested and see what that yields. If you have any other ideas, I’d love to hear them.



    If single emails go through but multiple ones like the preview and live mails don’t that sounds more like a server side restriction. Have a look in the logs and you can check that the emails are being generated and sending at least attempted. If this is all confirmed then it’s a case of taking this up with your hosting provider.


    Thanks for your reply. I’ve been corresponding with my web host (DreamHost) and it now appears that the problem may be caused by a new policy change in the way they handle email. I’ve pasted in their latest response here:

    I tested the form and received the email it sent. The email I received
    had the from address <>. You should have no problems
    sending emails out with the from address <>.

    The reason the from address suddenly became an issue is a mail policy
    change we made recently, to restrict the from address of emails that are
    sent through DreamHost’s servers. Emails sent by your website code should
    have a from address that correctly reflects that, such as
    <>. Many other from addresses, including ones from a
    major email provider (GMail, Yahoo, etc), will be blocked by our servers.
    It sounds like your php form is using the site visitor’s email addresses
    as the from address on the emails it sends. This is a technique called
    spoofing, where the DreamHost server is sending mail, but it’s pretending
    to be someone else (in this case, the site visitor). This technique has
    negatively affected the reputation of our mail servers (endangering our
    ability to host mail at all), and led to our admins implementing the
    current from address restrictions.

    Emails blocked from sending are not lost, but bounce back to the server
    user who hosts the site that sent the email. You can view them (they are
    just text files) in the Maildir/new and Maildir/cur directories on the

    If you have any other questions or issues, please let me know, I’m always
    happy to help!

    Is there any way I can adjust the settings in Subscribe2 to get around this limitation from DreamHost? Again, thanks for your help!



    You need to doe 3 things:

    1/ Create an email address on your hosting plan the meets the recommendations as per DreamHosts policy.

    2/ Create a new administrator level user in WordPress at Users->Add New using this email address

    3/ Visit Subscribe2->Settings and change the “Send email from” drop down to the name of this new user account and then click Submit at the bottom of the page.


    Thanks for the info. The steps you outlined above are actually the things I understood when I first saw the warning within the plugin. At that point, I set up an email address that was “on-domain.” My blog is, so I set up a WordPress admin level user with the email address

    I’ve tested this address and it can send and receive email no problem. (It uses Google Apps)

    I’ve also verified that Subscribe2 is set to send from the new admin user in Settings. Unfortunately, when I go to the Subscribe2 plugin, Settings>Send Email Preview, I still don’t get the email.

    As suggested by DreamHost, I’ve checked the mail logs, and if I’m understanding the correctly, it appears that the email is still being sent from my personal email address, which is “off-domain”.

    Here’s one of the logs I just now copied off the server:

    Return-Path: <>
    Received: by (Postfix)
    	id 2C1C818A6F9; Thu, 13 Sep 2012 10:36:45 -0700 (PDT)
    Date: Thu, 13 Sep 2012 10:36:45 -0700 (PDT)
    From: (Mail Delivery System)
    Subject: Undelivered Mail Returned to Sender
    Auto-Submitted: auto-replied
    MIME-Version: 1.0
    Content-Type: multipart/report; report-type=delivery-status;
    Content-Transfer-Encoding: 8bit
    Message-Id: <>
    This is a MIME-encapsulated message.
    Content-Description: Notification
    Content-Type: text/plain; charset=us-ascii
    This is the mail system at host
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    If you are a current customer of DreamHost, please contact our
    technical support team here
    If you are not a customer please use our contact form at.
    If you do so, please include this email in your support ticket. You can
    delete your own text from the attached returned message.
    		DreamHost Email Support
    <>: host[] said: 550
        5.7.1 Sender domain not allowed. Please read: (in
        reply to end of DATA command)
    Content-Description: Delivery report
    Content-Type: message/delivery-status
    Reporting-MTA: dns;
    X-Postfix-Queue-ID: 20C3C18A4F8
    X-Postfix-Sender: rfc822;
    Arrival-Date: Thu, 13 Sep 2012 10:36:45 -0700 (PDT)
    Final-Recipient: rfc822;
    Action: failed
    Status: 5.7.1
    Remote-MTA: dns;
    Diagnostic-Code: smtp; 550 5.7.1 Sender domain not allowed. Please read:
    Content-Description: Undelivered Message
    Content-Type: message/rfc822
    Content-Transfer-Encoding: 8bit
    Received: by (Postfix, from userid 11143723)
    	id 20C3C18A4F8; Thu, 13 Sep 2012 10:36:45 -0700 (PDT)
    Subject: [] Faithful Men
    Date: Thu, 13 Sep 2012 17:36:45 +0000
    From: Plain Text Full Preview <>
    Message-ID: <>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.1 (
    Reply-To: Plain Text Full Preview <>
    Precedence: list
    List-Id: =?UTF-8?Q?Joshua_and_Kelsie_Steele_=E2=80=93_Missionaries_proclaiming_Jes?=
    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: text/plain; charset="UTF-8"
    Dear Subscriber,
    Joshua and Kelsie have added a new post to their blog. We appreciate your
    interest in our ministry overseas.
    View this post online at:
    Posted by: Joshua
    Faithful Men
    The August issue of our newsletter, Overseas Field Report, is now available. In
    this issue we give you the latest news about our summer project, Carpathian
    Mountain Outreach 2012.
    Download the PDF here » [download#43#size#nohits]
    If you subscribe to Overseas Field Report by regular mail, you should be
    receiving a printed copy of this issue in the next week or so. As always, we
    greatly appreciate your prayers and support for our ministry.
    You received this e-mail because you asked to be notified when new updates are
    posted. If you wish to unsubscribe, please visit and adjust your preferences accordingly.

    Please let me know if there’s something I’m missing. Thank you!


    OK I just published a new post to my blog, and that email went out to everyone. So that’s 90% of the problem resolved.

    However, I still cannot get any other email function to work. This would include Settings>Email, the Send Email to Subscribers feature, or the preview of the Send Email to Subscribers feature. For all of those, it appears Subscribe2 is still trying to send from the email of the logged in user.

    Thoughts? Thanks.


    The preview and Send Mail pages are design to send from the email address of the currently logged in user so it’s working as expected.

    For the Preview it would be expected that it should be send to the currently logged in user and from them also – this works on most hosts as you are unlikely to spam yourself.

    For the Send Email page it would be expected that the person authoring the message should also be the sender rather than allowing different users to send messages that may appear to be coming from another users email address.

    To overcome your issues in using these areas perhaps it would be wise to use the account with the email address when logging into your blog.

    OK, that makes sense. Thanks so much for all your help!

    Hi there,

    We are continuing to have trouble sending email, and it’s clear that this is due to incompatibilities between DreamHost’s email policies and the Subscribe2 plugin. They are limiting us to no more than 200 emails per hour. Some of our blogs have in excess of 200 subscribers and so the notification process fails.

    DreamHost also says that, under their new policies, the subscription service has to log the IP address of each subscriber at the time of their subscription confirmation. The DreamHost rep I have been emailing with claims he is familiar with Subscribe2, and that just this week you adjusted the db tables to be compliant with their policies. He said that another customer contacted you with this same issue. He has checked our existing Subscribe2 db tables (like in the last 30 minutes) and says they are not the new, compatible type. We have installed every update of Subscribe2 that’s come out, and I haven’t seen this change. How do I get this new “DreamHost” compliant version of Subscribe2?

    Lastly, is there a way in Subscribe2 to adjust the number of emails sent per hour? If that could be limited to smaller batches of, say, 190, then we would be able stay under their limit. Any thoughts?

    Thanks again for your help on this. 🙂


    I’m very impressed with DreamHost right now. Their policies are clear and they are clearly communicating well given that they know about the changes I made to meet their policy.

    The updated version Dream Host are referring to is still in development. Another Dream Host user donated some money and asked for a solution. After sufficient testing I’ll roll the changes into the core code.

    As for setting the number of emails per hour – that is not part of Subscribe2 but there are solution in the WordPress plugins area or there is my paid solution.


    Thanks for your quick response. I’m glad to hear that a solution is in the works.

    I really like Subscribe2. We’ve used it for quite a while and it’s always served us well. I just sent you a donation through PayPal. I appreciate your work on this plugin and your prompt support.

    I’ll be looking forward to the new update when it comes out.

    Thanks again!

    Hi there joshukraine

    i’m was so happy to find out about the problems you had because i’m have problem using subscribe2 and now i know why.. i have been trying for 2 weeks to get this plugin ti work.

    i’m also ussing dreamhost services and i want to know please… did you mange to make this plugin work with Dreamhost and if you are using it today how can i configure it… because i can’t make it work… i’m gona try to create a account with e-mail account.. and see if things looks better.. i would love to hear from your experince with dreamhost…these days

    and hi there

    have you completed the update so the version of subscribe 2 can work with Dream Host demands…

    thank you both for your help



    Yes, I can confirm the necessary update has been part of the plugin for a while an the IP address, date and time are all recorded when a user is confirmed.

    hi mattyrob

    using the format did it.
    i thank you both for the information

    now i have more then 2000 subscribers on my list
    and i can only sent 100 per hour max

    i have tried to buy the
    WordPress Mail Queue (WPMQ) – plugin and i get the next message

    “Plugin purchasing is currently not available.”

    from where can i buy it and is it still update for wordpress last version and will it continue to be in the future…

    thank you


Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: Subscribe2] Emails not sending’ is closed to new replies.