Support » Plugin: Subscribe2 » [Plugin: Subscribe2] E-Mails not formatted, no images

  • Resolved Lutz.H

    (@lutzh-1)


    Hi MattyRob,

    sorry, it’s me again … 😉

    Changed my host account to an expensive one which can handle it’s own cron jobs, de-activated WordPress cron job. Second problem could have been not supported SMTP mail handling, so installed a plugin called “Configure SMTP”.

    This helpt with the mails when a comment has been written and manually mails can be sent, too. So the main problem seems to be fixed – thanks again for your help and patience!

    Nevertheless there are two problems left:

    1: There is still no automatically mail sent by Subscribe2. After half an hour after the set time I hit the button “Send Newsletter Again”, then the mails were sent! So I guess we come back to a problem with your plugin …
    Any idea what I could do?

    2: After I sent out the newsletter manually I saw it for the first time … and am a litle disappointed. It’s not formatted at all and containt no pictures. Even worse: it looks like that:

    Headline
    link

    text text text text text text text text text text text text text text text text text text text text text text text text text text text text text

    Headline
    link

    text text text text text text text text text text text text text text text text text text text text text text text text text text text text text

    and so on …

    So the reader is not able to check out which parts belong together. Headline + link seem to be one unit, the text another one.

    To make it short: I really, reall do hope that there is a way to format that mails and put some pictures into it – or otherwise all our work, my time and my money would have been spent for nothing!

    Again: If you can fix all this, I’ll donate with pleasure!

    Thanks again in advance and kind regards,
    Lutz

    http://wordpress.org/extend/plugins/subscribe2/

Viewing 15 replies - 1 through 15 (of 44 total)
  • mattyrob

    (@mattyrob)

    @lutz.H,

    Why have you disabled WordPress cron? Subscribe2 needs that working to send notifications.

    If you have disabled it then you need to make sue the server cron table is making regular calls on the WordPress cron files so that the periodic tasks get run.

    Also, the free version of Subscribe2 sends plain text emails only. If you want to retains formatting and images (bearing in mind that Subscribe2 takes a excerpt of your post) then you would need to but the HTML version of Subscribe2.

    Before you do that make sure you can format emails using your theme CSS by sending preview emails in per post mode having added DIV tags as per your theme to the Subscribe2 templates.

    Lutz.H

    (@lutzh-1)

    @mattyrob,

    in almost all support post is written that there is a bug concerning the wp cron job and that you have to replace it by an external (“real”) cron job, e.g. here:
    http://buildyourblog.net/
    or here:
    http://wpdailybits.com/blog/replace-wordpress-cron-with-real-cron-job/74

    Shall I reset the wp cron job and cancel the cron job by my hoster?

    Formatting + images: I would buy the pro version if it helps ;))
    But I’m not quite sure if it does – because …
    – I want to send a daily newsletter
    – the theme (Pagelines) doesn’t concern with mails at all, but I could use a plugin if you can give me a hint which one will work that way you explained

    Maybe we can make a deal that I can try out Subscribe2 Pro for 30 days and if it doesn’t work I can get a refund? How much would the Pro version cost?

    Kind regards,
    Lutz

    mattyrob

    (@mattyrob)

    @lutz.H,

    There have been issues with WordPress cron over the years but those 2 articles are a minimum of a year old now. Cron has been subject to quite a few improvements in the last couple of WordPress releases.

    It still may fail on certain server configurations but I would certainly try it ‘out of the box’ before going along the route of applying a fix that might be unnecessary.

    The pro version of Subscribe2 can still send daily messages but to be clear Subscribe2 (free) only allows HTML to Registered Users (an incentive to register). The HTML (paid) version sends HTML emails to Public Subscribers by default rather than plain text BUT you still need to apply some HTML and CSS in the templates to do the styling.

    Subscribe2 is mainly designed to reflect your sites appearance in the email. If you just want fancy looking emails with minimal effort you may be better with JetPack.

    Lutz.H

    (@lutzh-1)

    Hi Matthew,

    seems as if I don’t have mich control of the way “Jetpack” is working and sending out mail newsletters. I guees your way is the more complex, but the secure and individual one. And if I can manage this (with your help) I would prefer the last option. Especially because we have gone such a long way together ;))

    Alrigh so, please let me know how to get the Pro vrsion and how where I cand find a guide how to configure the individual look (images and so on) …

    Kind regards,
    Lutz

    mattyrob

    (@mattyrob)

    @lutz,

    Sadly, there isn’t a guide I can link you to, writing one is something I haven’t found time for and it’s a process that is very much theme specific. There is a specific forum for the paid version and I’ll always help you out as much as I can on there.

    The HTML version is available here.

    Lutz.H

    (@lutzh-1)

    MattyRob: I asked my hoster to send be a repot of every cron job running now. It did every hour and I tried 4 automated newsletters since then, but no one ws sent out. Again: When I set it manually by hitting that button the mails are sent. I tried with and without the wp-cron activated/deactivated in wp-config.php – didn’t make a difference.
    So, before I start optimizing the mail styling (HTML version) we should fix that problem. As Jetpack is no option, I hope you’ll help me with that!

    Kind regards
    Lutz

    Lutz.H

    (@lutzh-1)

    @mattyrob: Hey, found a bug! The system sends out the newsletter on UTC time, not at site time. The problem: Thre lines below you write something like “Next mail send wen time is later than …” followed by the PAGE time – so I thought that’s the used time. Seems as if it’s not … ;))

    But unfortunately that doesn’t solve my problem totally. Only one single mail has been sent out, and that went to the outgoing mail account itself (the one that I entered in the SMTP plugin as “sender mail address”. All the other recipiants didn’t get the mail.

    Sorry, Matt, but this looks like a bug in the Subscribe2 plugin, don’t you think so? Or what else can I do to make that work?

    Maybe this will give you a hint – or is it another problem?
    In the sent newsletter mail there have been missing the two news mails from today; only the old news of yesterday have been included. Is it possible, that there hasn’t been created a new “newsletter job”? And that’s why there wasn’t a new entry in the crop job cue or something like that?

    Kind regards,
    Lutz

    mattyrob

    (@mattyrob)

    @lutz,

    Debugging WP cron is not something within my experience area. Does this article help though?

    Lutz.H

    (@lutzh-1)

    Addendum: Ii it possible that Subscribe2 “reminds” which posts have been sent already? Or how does the tool decide which posts go into the newsletter mail and which don’t? So maybe Subscribe2 got confused by all my testing and manual mail sendings and previews and “Send Again” actions? Just an idea …

    Lutz.H

    (@lutzh-1)

    @mattyrob,

    thanks, but this is exactly what I’m doing already. And as I just said: Because ONE mail has sent out automatically, I guess that this is no problem of the cron job anymore …
    Hope you’ll help!!!

    Kind regards,
    Lutz

    mattyrob

    (@mattyrob)

    @lutz,

    Hmm, you may be on to something there. If you’ve been changing lots of settings it may be that things have gotten mixed up.

    Try installing the WP-Crontrol and have a look at the core scheduled events and see if they execute and move forward. There should also be a subscribe2_cron even in the list too.

    Lutz.H

    (@lutzh-1)

    @mattyrob,

    I’m already using that tool and that has made up this idea. Here I find an entry “s2_digest_cron” for e.g. 18:00 hours and the header shows “GMT/UTC” – that’s a difference of 2 hours on my location (site time).

    Lutz.H

    (@lutzh-1)

    @mattyrob,

    and I’ve another bug report for you: If “Subscribe2 – Settings” says e.g. 6pm (it’s really UTC!!!) for the next newsletter, I wait until 6:30 UTC and then set the new time for e.g. 7pm UTC (because it didn’t work) then the cron job entry “s2_digest_cron” is set for the NEXT day! I guess because I use the setting “once a day”. In some way it’s correct, but I guess most users think like me: “Hey, it’s 6:30pm UTC, when I set next send out time to 7pm UTC then it’s going to send in half an hour.” Right! But it doesn’t, because Subscribe2 thinks, it already has sent out the newsletter for today.

    From my point of view that’s misleading. And if I had the choice, I definetly would choose to decide by myself if it’s okay to send the next newsletter in half an hour (“again”) … for whatever the reason might be.

    Maybe you can change that in th next version? I would appreciate that change ;))

    But for now I know that I can test the tool only once a day – or is there some trick how to change the date of the cron job (“s2_digest_cron”), too?

    I don’t want to change the settings to “one mail for each post” because I would like to test if the new posts are gathered correctly …

    Kind regards,
    Lutz

    mattyrob

    (@mattyrob)

    @lutz,

    Is that time still in the future for you?

    Lutz.H

    (@lutzh-1)

    @mattyrob,

    yes, all times I mentioned in my post above are in UTC, so I have had UTC 6:30pm and programmed the next ride for 7pm UTC.

Viewing 15 replies - 1 through 15 (of 44 total)
  • The topic ‘[Plugin: Subscribe2] E-Mails not formatted, no images’ is closed to new replies.