Support » Plugin: Subscribe2 » [Plugin: Subscribe2] Cant add link (for unsubscribe)

  • Under email templates I have an anchor tag that brings people to a page where they can unsubscribe. However, the hyperlink does not show in the emails. I have set it send to send out HTML excerpt thinking this would fix the issue but still nothing. Code is below:

    {BLOGNAME} has posted a new item, '{TITLE}'
    
    {POST}
    
    You may view the latest post at
    {PERMALINK}
    
    You received this e-mail because you asked to be notified when new updates are posted.  To unsubscribe, please click <a href="http://niemuths.com/subscription">here</a>
    
    Best regards,
    {MYNAME}
    {EMAIL}

    Thanks for the help!

    http://wordpress.org/extend/plugins/subscribe2/

Viewing 9 replies - 1 through 9 (of 9 total)
  • @gianthobbit,

    Any HTML tags you put into the template (including anchor tags) will get stripped out for the plaintext emails.

    You therefore need to include the link for plaintext recipients, something like this:

    To unsubscribe, please visit<a href="http://niemuths.com/subscription">http://niemuths.com/subscription</a>

    I have it set to send the emails as html with except but it appears as if there going out as plain text…

    @gianthobbit,

    You haven’t set it to send as html with except as there is not such setting.

    You have either chose to receive HTML excerpts at your own email address based on your personal subscription at Subscribe2->Your Subscriptions or you have set all future users who sign up to be automatically subscribed to receive HTML excerpts in Subscribe2->Settings.

    Is there a way to move current subscribers to receive the HTML excerpts. If not could I export, save, then re-import to get them to have the new HTML setting?

    @gianthobbit,

    Registered Users – Yes, Filter on them at Subscribe2->Subscribers and bulk change the settings at the bottom of the screen.

    Public Subscribers – No.

    Hmm I dont see any options like that, this is what I see

    http://cl.ly/2L0G1e0X0n3r24411n3P

    I see it now if I filter to registered users. How can I make a public subscribe a registered user?

    If I export, delete all, then re-add will they come through as html except then?

    @gianthobbit,

    You’d have to delete all the Public Subscribers and then manually add them all at Users->Add New.

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Subscribe2] Cant add link (for unsubscribe)’ is closed to new replies.