Cannot uninstall (8 posts)

  1. jrlorson
    Posted 5 years ago #

    Hi - I haven't been able to get the plugin to work. I configured it; but on my blog, the widget link just displays a link for me to configure my own options (again). Also I get error messages just trying to configure it, and sometimes when I just click on the link on my blog page.

    I tried to uninstall it, and got the following error message:

    Fatal error: Call to a member function get_user_meta() on a non-object in /home/content/15/7686215/html/wp-content/plugins/subscribe2/uninstall.php on line 18

    Please tell me how I can uninstall this plugin.
    Thank you.


  2. couponsncharities
    Posted 5 years ago #

    I'm getting the same error.

  3. mattyrob
    Posted 5 years ago #


    Log out and you'll see the form - you see a link because you are still logged in to your site.

    There is a known issue with the uninstaller in 6.4 that will be fixed in the 6.5 release and is already pacthed in the development code, if you want to uninstall use the trunk uninstaller from here, upload it to wp-content/plugins/subscribe2/ on your server.

  4. jrlorson
    Posted 5 years ago #

    Thanks for your reply - but I honestly am not savvy enough to do that. I guess I'l just wait for the update.

  5. couponsncharities
    Posted 5 years ago #

    All you need to do is copy and replace all that code into the uninstaller file under wp-content/plugins/subscribe2/. Then go back into WP and uninstall as usual.

  6. charise
    Posted 5 years ago #

    I deleted the files from the server before seeing this post about the trunk uninstaller and now I can't get rid of the white screen of death.

    Will reinstalling the plugin and uninstalling it properly fix the problem or do I have to restore my entire site from a backup file?

  7. mattyrob
    Posted 5 years ago #


    It sounds like you have not completely deleted the plugin when you did it manually or you deleted something extra that you shouldn't have done.

    Try reinstalling the plugin first and if that works then uninstall it using the updated uninstaller or wait for version 6.5.

    If reinstalling the plugin doesn't help then it's a restore from a backup.

  8. charise
    Posted 5 years ago #


    Thanks for the quick response. Seems like it could have been unrelated to your plugin. Either way, onto a full restore from last night's backup.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Subscribe2
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic