Support » Plugin: Subscribe To Comments Reloaded » [Plugin: Subscribe To Comments Reloaded] Subscription page doesn't show any form

  • Resolved 3nd3r

    (@3nd3r)


    So, first of all, fantastic plugin (I’ve voted max for it already), but I still realize you can help me anyway 😉

    Well, my blog is http://www.pajareo.com, and you can reach subscription page, but it doesn’t show any form to insert email… For example: http://www.pajareo.com/administrar-suscripciones?srp=8749

    I’ve installed a little modified Motion theme (child), and this is my lists of plugins:

    About Me 3000 ( 1.95 )
       AddThis Social Bookmarking Widget ( 1.6.8 )
       Advertising Manager ( 3.4.19 )
       Akismet ( 2.5.2 )
       All in One Webmaster ( 6.9.9.3 )
       BlogUpp! - Blog Promotion ( 1.5 )
       Broken Link Checker ( 1.2.3 )
       fortunate ( 1.4.4 )
       Google XML Sitemaps ( 3.2.4 )
       Greg's High Performance SEO ( 1.4.5 )
       GTranslate ( 1.0.12 )
       Link Summarizer ( 1.8 )
       nrelate Related Content ( 0.42.6 )
       PageRank Widget ( 0.7 )
       Random Posts widget ( 1.5.0 )
       Random Text ( 0.2.6 )
       Search & Replace ( 2.6.0 )
       WordPress.com Stats ( 1.7.5 )
       Subscribe to Comments Reloaded ( 1.6 )
       Tagline Rotator ( 2.2 )
       W3 Total Cache ( 0.9.1.3 )
       Wordbooler ( 1.8.20 )
       WordPress SEO Pager ( 1.97 for WP 2.5+ )
       WP BBCodes to HTML Parser ( 1.5 )
       WP-Cleanup ( 1.1.0 )
       WP Original source ( 1.1 )
       WPtouch ( 1.9.21.1 )

    Hope you can help me. Thanks for your time!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor Jason Crouse

    (@coolmann)

    You may want to take a look at this thread and this one. Also, I suspect W3 Total Cache is creating some conflict.

    Camu

    Well, the first link talks about

    The WordPress SEO by Yoast plugin did not recognize the URL that was being dynamically created for the management page and redirected to the blog home page instead.

    and this is not my issue. The page shows right, but it doesn’t show any form to input email. Also, I haven’t installed that plugin, and there’s no Redirect ugly URL’s to clean permalinks or similar option in W3TC.

    The second link talks about reactivating ‘wpautop’. How can I know if there’s a plugin which use that function?

    I hope we can find a solution for this. Thank you.

    Plugin Contributor Jason Crouse

    (@coolmann)

    Hi,

    you may want to wait until version 1.6.1 is released. I will add a new option to allow users to manually create the management page in their blog and so circumvent this kind of conflicts with other plugins/themes.

    Thank you,
    Camu

    PS: I suspect the culprit is one of your SEO plugins or All in One Webmaster.

    Maybe, I don’t know… I will try later disabling them and make a test… I will tell you.

    Thanks for your feedback. Do you hace an estimate timing about next release of your plugin?

    Plugin Contributor Jason Crouse

    (@coolmann)

    It should be ready in a couple of weeks, I assume. But I can’t guarantee that. In the meanwhile, you will have to edit the plugin’s code following these instructions.

    Camu

    Ok I’ll do that!

    Thank you!

    Plugin Contributor Jason Crouse

    (@coolmann)

    Great, please keep me posted.

    Camu

    I’ve got a problem with this solution…

    I’ve created subscribe.php, uploaded to my theme directory, created an empty page called “Administrar suscripciones” with that template…

    But if you load, for example, this page you only get to this page again…

    So, this is the subscribe.php :

    <?php
    /*
         Template Name: Subscribe To Comments
    */
    get_header(); ?>
    
    <div id="main">
    <div id="contentfull">
    
    <?php if (have_posts()) : ?>
    <?php while (have_posts()) : the_post(); ?>
    
    <?php if (function_exists('wp_list_comments')): ?>
    <div <?php post_class(); ?> id="post-<?php the_ID(); ?>">
    <?php else : ?>
    <div class="post" id="post-<?php the_ID(); ?>">
    <?php endif; ?>
    
    <div class="posttop">
    <h2 class="posttitle"><a href="<?php the_permalink() ?>" rel="bookmark" title="Permalink a <?php the_title_attribute(); ?>"><?php the_title(); ?></a></h2>
    </div><!-- /posttop -->
    
    <div class="postcontent">
         <?php if (function_exists('subscribe_reloaded_show')) subscribe_reloaded_show(); ?>
    <div class="linkpages"><?php wp_link_pages( 'link_before=<span>&link_after=</span>' ); ?></div>
    </div><!-- /postcontent -->
    <small><?php edit_post_link('Admin: Edit this entry?','',''); ?></small>
    </div><!-- /post -->
    
    <div id="comments">
    <?php if (function_exists('wp_list_comments')): ?>
    <!-- WP 2.7 and above -->
    <?php comments_template('', true); ?>
    
    <?php else : ?>
    <!-- WP 2.6 and below -->
    <?php comments_template(); ?>
    <?php endif; ?>
    </div> <!-- Closes Comment -->
    
    <?php endwhile; ?>
    <?php else : ?>
    <div class="post">
    <div class="posttop">
    <h2 class="posttitle"><a href="#">Oops!</a></h2>
    </div><!-- /posttop -->
    <div class="postcontent">
    <p>Lo que buscas parece que no est&aacute; aqu&iacute;...</p>
    </div><!-- /postcontent -->
    </div><!-- /post -->
    <?php endif; ?>
    
    </div><!-- /content -->
    
    </div><!-- /main -->
    <?php get_footer(); ?>

    What can I do to solve this?

    Plugin Contributor Jason Crouse

    (@coolmann)

    Did you comment out that line in my plugin’s source code? What permalink are you using for the page you manually created?

    Camu

    Yes I did comment out that line

    This is the permalink: http://www.pajareo.com/administrar-suscripciones

    Plugin Contributor Jason Crouse

    (@coolmann)

    Sorry, but I think it’s a conflict with something else. I really don’t know what else could it be.

    Sorry to read that 🙁

    Please if you have any idea on what’s going on this in any time, post here, and I will give it another chance.

    Thanks anyway

    Plugin Contributor Jason Crouse

    (@coolmann)

    Sure,

    Camu.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Subscribe To Comments Reloaded] Subscription page doesn't show any form’ is closed to new replies.