WordPress.org

Support

Support » Plugins and Hacks » Subscribe To Comments Reloaded » [Resolved] [Plugin: Subscribe To Comments Reloaded] Subscribers not receiving emails

[Resolved] [Plugin: Subscribe To Comments Reloaded] Subscribers not receiving emails

  • Hi Camu! I love the simplicity of your plugin, but just can’t get it to work.

    Okay. So here’s what happens. I only offer a link to subscribe without posting. So, subscribers click the link to subscribe, enter their email address and click “Send.” I get an email saying someone subscribed to the comments. Great.

    Then I go to the settings>manage subscriptions area to confirm their subscription and there are no email addresses listed when I click “list all the subscriptions.” And they’re not receiving email notifications.

    As you mentioned in some of the earlier forum posts, I have checked all the fields on the Options and Messages pages. All the ones you have mentioned in the earlier posts are filled in. I’m really not sure what to do next to resolve my issue.

    Thanks in advance for your time and efforts to resolve my problem.

    The details: I have a ton of multisites and use Default Blog to create each one, carrying settings from one blog to the other, so all the multisites are similar. I do use other plugins and will be happy to share which ones if you think it’s relevant.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Contributor Jason Crouse

    @coolmann

    Hi there,

    are you using Proper Network Activation in your multisite environment as per my installation quick setup guide?

    Thanks,
    Camu

    Thanks so much for the quick response.

    Yes. I installed the Proper Network Activation when I first using your plugin and it is still installed.

    Plugin Contributor Jason Crouse

    @coolmann

    Could you check if, for each blog in your network, you have the corresponding table for my plugin? wp_x_subscribe_reloaded

    Thanks.

    I certainly wouldn’t mind, but I don’t know where to find the tables. Can you steer me in the right direction?

    Plugin Contributor Jason Crouse

    @coolmann

    Have you ever used phpmyadmin?

    Camu

    Nope. But I was able to login and find the right direction. Learn something new every day!

    It doesn’t look like there is a wp_x_subscribe_reloaded table for each blog. I only found 3 instances of the table (out of 20 or so blogs). I am sure I must have done something completely wrong somewhere, but is there something I can do to fix it?

    Plugin Contributor Jason Crouse

    @coolmann

    I assume your php/mysql went out of memory while creating all the tables. You can just disable/enable my plugin again and see if it creates all the tables this time.

    Camu

    So, I went to one of my blogs>plugins>subscribe to comments reloaded>network deactivate. It deactivated all my blogs. Then I clicked network activate, and it showed wordpress activating all of them.

    I went back to my tables, refreshed the page and I only found the 3 instances again. Did I miss something somewhere?

    Plugin Contributor Jason Crouse

    @coolmann

    No you did everything right. It seems like the network activation process fails somewhere. You would need access to your mysql log file in order to see what is going on under the hood.

    Camu

    Okay. I’ve looked around in there and can’t find what I think I’m looking for. I looked at dev.mysql.com and found this:

    If you specify no name for the general query log file, the default name is host_name.log. The server creates the file in the data directory unless an absolute path name is given to specify a different directory.

    Is this what I’m looking for? Is it in with my databases?

    Plugin Contributor Jason Crouse

    @coolmann

    Yes, that’s exactly what you would be looking for 🙂 Can’t you ask your hosting provider to help you with this matter?

    Thanks,
    Camu

    I can do that. Once I find the log, would they be the ones to help me out? Or should I come back here to clear up what’s going on?

    Plugin Contributor Jason Crouse

    @coolmann

    Well, once you find the reason why the activation is not being completed (out of memory, error in sql, etc) let me know and we’ll figure it out together.

    Camu

    Okay. Thanks so much camu.

    Plugin Contributor Jason Crouse

    @coolmann

    Sure, no problem.

    Camu

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] [Plugin: Subscribe To Comments Reloaded] Subscribers not receiving emails’ is closed to new replies.
Skip to toolbar