WordPress.org

Support

Support » Plugins and Hacks » Subscribe To Comments Reloaded » [Resolved] [Plugin: Subscribe To Comments Reloaded] Modify Subscription Management Page

[Resolved] [Plugin: Subscribe To Comments Reloaded] Modify Subscription Management Page

  • Hi,

    In the configuration screen for your plugin under Management Page – you write: “This page does not actually exist in the system, but its link must follow your permalink structure.”

    I’m curious whether there’s an easy way to modify this page – more specifically I would like to introduce certain widgets in the right column.

    I use the “Executable PHP Widget” plugin which allows me to conditionally select what widgets will appear on various pages. I cannot use this plugin to tailor the Management Page as the page does not actually exist.

    I am using the latest version of your plugin (1.6).

    Some feedback would be much appreciated.

    Thanks,

    Robert

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Contributor Jason Crouse

    @coolmann

    You may want to take a look at this page

    http://lab.duechiacchiere.it/index.php?topic=71.0

    Cheers,
    Camu

    Camu,

    Thanks for that link. I tried as suggested but there were issues. I need to take a step back here and explain another issue that is happening which is probably impacting the setting up of a “real Management Page”. (I will come back to the setting up of a “real” page later… once the below issue is resolved)

    Despite disabling all plugins (except for yours of course) – I am still having URL issues.

    – I run pretty permalinks in format: …/2011/03/01/sample-post/
    – I searched your forums and found similar issues but not exactly the same.
    – I added a / (forward slash) to “Management Page” option as suggested in one of your forum posts : /comment-subscriptions/
    – All works fine… after clicking “Manage your subscriptions” at bottom of comment the page “Manage your Subscriptions” is displayed.
    – Title of page is fine but URL is weird: …/2010/10/27/

    As I said this even happens when all plugins are deactivated except STCR.

    My temporary work around is to add a redirect from …/2010/10/27/ to /comment-subscriptions/

    Any assistance would be greatly appreciated.

    Thanks,

    Robert

    PS: tell me if I need to start another thread.

    Plugin Contributor Jason Crouse

    @coolmann

    Hi there,

    do you have any special rules in your .htaccess? Could I get access to your site to take a look at your settings and perform some tests?

    Camu

    Camu,

    More than happy to arrange something as far as access.
    I’m reluctant to publish content of .htaccess in this forum but happy to email you.

    What is best email address to contact you on?

    Robert

    Plugin Contributor Jason Crouse

    @coolmann

    Sure, this is understandable. You can contact me at info at (domain removed) dot it. This message will be edited in a few minutes to avoid spammers to grab it, so write it down quick 🙂

    Camu

    Thanks Camu,

    Email sent and profile created and enabled.

    Cheers,

    Robert

    Plugin Contributor Jason Crouse

    @coolmann

    Thank you,

    got it. I’ll try to give it a look as soon as possible.

    Camu

    Plugin Contributor Jason Crouse

    @coolmann

    So it turns out it’s a problem with your template. Please let me know if you have news about it.

    Camu

    I’m not 100% convinced that it is a template issue.

    The “Manage subscriptions” page has a post-ID of 9999999.
    Have delved into template code and it’s the-permalink() WP function that retrieves the URL based on the above post-ID.

    How can WP retrieve permalink for a post/page that does not exist?

    Robert

    Plugin Contributor Jason Crouse

    @coolmann

    You were right indeed! It was a bug in my plugin. Please test the new file I sent you yesterday, if it works, I’ll release a new version asap 🙂

    Camu

    PS: I think you can deactivate my account on your blog now.

    Camu,

    That is great news !
    I did not see the file yesterday.
    Could you resend?
    Will test and provide feedback.

    Robert

    Camu,

    No go…

    After update – Page title on “Manage subscriptions” page still has URL of …/2010/10/27/

    Robert

    Plugin Contributor Jason Crouse

    @coolmann

    Hey Robert,

    as I found out, it seems like your template is not using the_permalink() to generate the link for that page. Again, you may want to create a real page and follow that route, if you don’t want to edit your template 🙂

    Camu

    Camu,

    (See email that I sent you).

    My theme template uses get_permalink() rather than the_permalink() to generate the URL for post.

    Are we getting warmer?

    Robert

    Plugin Contributor Jason Crouse

    @coolmann

    Robert,

    as per my earlier email message, you should be safe in replacing get_permalink() with the_permalink() in your template. No need to create an actual page template, I guess. Please let me know if this solves the problem.

    Camu

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘[Resolved] [Plugin: Subscribe To Comments Reloaded] Modify Subscription Management Page’ is closed to new replies.
Skip to toolbar