WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Subscribe To Comments Reloaded] confirmation sent correctly, but no emails afterwards.

[Plugin: Subscribe To Comments Reloaded] confirmation sent correctly, but no emails afterwards.

  • I am having a problem with a new installation of STCR on the site http://www.shanzhuoboshi.com . I used to run subscribe-to-comments and have just upgraded to STCR. The original STC worked fine for over a year. When upgrading, I followed the directions exactly (disable STC, install STCR, activate STCR, deactive, reactive, etc.). I am using WP 3.2.1 and STCR 2.0.2. Let admin subscribe is set to yes.

    The problem I am having is that the confirmation email is sent correctly, but once activated by the user, no email is sent when new comments are published. I have tried for readers who have not signed in, readers who have signed in, and admins. I have also tried subscribing without commenting, and subscribing while commenting. Neither seems to work. I have confirmed that the status after activation via email is in fact set to Y..

    The plugin looks great, and I hope to get a chance to use it, but so far can’t seem to figure out why it isn’t working.

    BTW….I have set up a custom management page, and checked to make sure that it is in fact working. It is. The custom link structure also appears to be correct.

    http://wordpress.org/extend/plugins/subscribe-to-comments-reloaded/

Viewing 15 replies - 1 through 15 (of 17 total)
  • btw….I sent you a msg via the “contact me” link in the “other notes” section of the plugin page on wordpress.org about a simplified chinese translation I made of the po and mo files. Let me know if you are interested, and how I can send it to you.

    Plugin Contributor Jason Crouse

    @coolmann

    Yes, thanks a lot. I’ve just been busy with other stuff, I’ll get back to you asap 🙂

    Camu

    Plugin Contributor Jason Crouse

    @coolmann

    As for your problem, do you also have WordPress’ comment approval enabled? My plugin only sends emails when comments are approved.

    Camu

    comment approval isn’t enabled….emails aren’t being sent on comments that are directly published

    also, posting comments takes a surprisingly long amount of time

    it looks like some emails are coming through and some are not. I think the subscriptions made using the old STC are working, while ones made with STCR are not….is that possible?

    Not sure how to debug this further

    Plugin Contributor Jason Crouse

    @coolmann

    Are you using both STC and STCR at the same time?

    no

    it looks like some of the notifications are coming through (1 out of 10 comments). They seem to all be from articles that were subscribed to using STC and not STCR. Also, it seems that if a comment is held for moderation, the email gets sent once the comment is approved….but not if the comment is directly published.

    Still not sure how to debug this…..how can I find the problem.

    Plugin Contributor Jason Crouse

    @coolmann

    I am currently out of town, I’ll help you debug this issue as soon as I come back 🙂 In the meanwhile make sure it’s not a conflict with another plugin. Disable everything except STCR and see what happens…

    It has been about a month now…..are you back yet???

    I was unable to find any conflicts with other plugins.

    I did notice that if I subscribe myself (blog admin) and no one else is subscribed, I don’t get mail……but if someone else subscribes after me, everything seems to start working.

    It is very strange, and I really hope you can help me debug further.

    Plugin Contributor Jason Crouse

    @coolmann

    Thanks for reminding me about this, it had slipped through the cracks 🙁 Please contact me at

    la buca delle lettere

    so that we can troubleshoot your issue

    Camu

    No problem….just contacted you via that form. The plugin is acting VERY wierd and I can’t figure out why.

    Have you considered the possibility that with a different format using STCR, some e-mails are ending up in users’ spam folders?

    Are you using the standard way to send e-mail, or have you set up a plugin that delivers e-mail via SMTP? E-mails delivered the latter way have a much greater chance getting delivered properly to users.

    Plugin Contributor Jason Crouse

    @coolmann

    Good point, Steve!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Subscribe To Comments Reloaded] confirmation sent correctly, but no emails afterwards.’ is closed to new replies.