Support » Plugin: Subscribe to Comments » [Plugin: Subscribe to Comments] Alignment of the check box

Viewing 11 replies - 1 through 11 (of 11 total)
  • Same here, and it seems we’re using the same theme (“Salutation”). If you can confirm me it, we could perhaps contact parallelus for a support, instead…

    tnx in advance,
    gabriele

    Nuno

    (@nuno-adrego)

    Yes, it’s “Salutation” theme :/

    I have the same problem, but my theme is this: Hyperspace (http://www.ufothemes.com/themes/hyperspace/). How I can fix it?

    A greeting.

    Hi, I also have the salutaion theme. to resolve your problem edit the following file from your jetpack plugin page : jetpack/modules/subscriptions.php

    find this :

    // Check if Mark Jaquith's Subscribe to Comments plugin is active - if so, suppress Jetpack checkbox
    
    		$str = '';
    
    		if ( FALSE === has_filter( 'comment_form', 'show_subscription_checkbox' ) && 1 == get_option( 'stc_enabled', 1 ) ) {
    			// Subscribe to comments checkbox
    			$str .= '<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"' . $comments_checked . ' /> ';
    			$str .= '<label class="subscribe-label" id="subscribe-label" for="subscribe_comments">' . __( 'Notify me of follow-up comments by email.', 'jetpack' ) . '</label>';
    			$str .= '</p>';
    		}
    
    		if ( 1 == get_option( 'stb_enabled', 1 ) ) {
    			// Subscribe to blog checkbox
    			$str .= '<p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"' . $blog_checked . ' /> ';
    			$str .=	'<label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">' . __( 'Notify me of new posts by email.', 'jetpack' ) . '</label>';
    			$str .= '</p>';
    		}
    
    		echo apply_filters( 'jetpack_comment_subscription_form', $str );
    	 }

    replace by this :

    // Check if Mark Jaquith's Subscribe to Comments plugin is active - if so, suppress Jetpack checkbox
    
    		$str = '';
    
    		if ( FALSE === has_filter( 'comment_form', 'show_subscription_checkbox' ) && 1 == get_option( 'stc_enabled', 1 ) ) {
    			// Subscribe to comments checkbox
    			$str .= '<p class="comment-subscription-form" style="margin-top:25px;"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="float:left; width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"' . $comments_checked . ' /> ';
    			$str .= '<label class="subscribe-label" id="subscribe-label" for="subscribe_comments">' . __( 'Notify me of follow-up comments by email.', 'jetpack' ) . '</label>';
    			$str .= '</p>';
    		}
    
    		if ( 1 == get_option( 'stb_enabled', 1 ) ) {
    			// Subscribe to blog checkbox
    			$str .= '<p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="float:left; width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"' . $blog_checked . ' /> ';
    			$str .=	'<label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">' . __( 'Notify me of new posts by email.', 'jetpack' ) . '</label>';
    			$str .= '</p>';
    		}
    
    		echo apply_filters( 'jetpack_comment_subscription_form', $str );
    	 }

    regards !

    But i haven´t this plugin, a have Jetpack Lite, and what relationship the “Subscribe To Comments” plugin for that?

    if your are using jetpack plug in
    Add below CSS into your style.css file

    p.comment-subscription-form input#subscribe_comments
    {
    float: left;
    margin-right: 10px;
    margin-left: 10px;
    }
    p.comment-subscription-form input#subscribe_blog
    {
    float: left;
    margin-right: 10px;
    margin-left: 10px;
    }

    let me know if you face any problem

    Thanks, but don´t work 🙁

    can u send me u r URL I can Help

    This is my blog: http://acalu.es/

    Add these lines to your style.css

    p.subscribe-to-comments
    {
    padding-top: 20px;
    }
    
    p.subscribe-to-comments input#subscribe
    {
    float:left;
    margin-right: 10px;
    }

    And remove below code from your Style.css at Line Number:941

    #commentform label {
    float: left;
    width: 100%;
    }

    This should work..
    Let me know if you face any problems.

    if face any problems regarding wordpress or anything contact me through my blog http://www.arungudelli.com

    Thank you very much, it worked!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Subscribe to Comments] Alignment of the check box’ is closed to new replies.