Support » Plugin: SublimeVideo (deprecated) » [Plugin: SublimeVideo] class="sublime zoom" doesn't work

  • Normal mode works fine, but light box mode doesn’t. Screen goes gray but nothing happens.

    I don’t think it’s something with my setup because it works when I type out the <video> code directly in HTML editor…

    This plugin would be the thing because switching to Visual editor magles the <video> tag…

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jon Breitenbucher



    Plugin Author Jon Breitenbucher


    The test I have for the most recent version works as intended.

    Here is the shortcode I used

    [sublimevideo location="" width="600" height="338" thumbnail="" m4v="" mp4="" class="sublime zoom"]

    You wouldn’t need the full paths if you were storing videos, thumbnails, and poster images in a central location.

    So I do not know what the issue could be, but as far as I can tell my plugin is working as intended. The plugin only looks for the shortcode and inserts the necessary <video> tag. It does nothing to a manually entered <video> tag.

    So what’s the deal with having both m4v and mp4 file? I thought they were both mpeg4 video…

    Plugin Author Jon Breitenbucher


    You would need to ask the makers of the video player. Their example code calls for both and as you found it doesn’t work without both.

    I found that everything worked fine including the Zoom function. Well done to the makers a brilliant job.




    I’m Rémy from the SublimeVideo team, thanks for this plugin, I think it helps many people to start using SublimeVideo in their WordPress blogs. However, we think it has some limitations that’s why we are in the process of building an official plugin (with a “video embedding helper” etc.).

    Just to clarify the question above (even if it’s a bit old now):

    Using .m4v AND .mp4 is indeed unnecessary, as explained in our documentation “we recommend linking directly to a MP4 source (href attribute) to enable compatibility with mobile devices where the lightbox effect is currently not supported.”. So the real point is to put a link to a mobile-compatible source (i.e. a H.264 file, it can be .mp4, .m4v or even .mov). In that sense the plugin is a bit misleading since it forces to set a m4v source where you could put virtually any source you want.

    Also, I got some feedback when a user wanted to use the “m4v” attribute without the “zoom” class, in that case it shouldn’t set up the lightbox effect.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: SublimeVideo] class="sublime zoom" doesn't work’ is closed to new replies.