WordPress.org

Support

Support » Plugins and Hacks » Styles » [Resolved] [Plugin: Styles] Some bugs?

[Resolved] [Plugin: Styles] Some bugs?

  • Hi,

    I know that this plugin has not been fully tested in the latest WP but anyway:
    1. Loaded and activated plugin, no problems occured
    2. I got to Appearence and Style and changed some fonts for menu, worked OK
    3. I went back to Appearence and Style and now the style for the Style has changed, previous I had some small images but now I have normal blue links and every field is opened
    4. when I try to change back the fonts and press Update I ony get answer: Do tou really want to do this! No Yes or No Option cant be found so I cant use the pluging at the moment!
    5. I went to Settings for Style and then its stated: Support License Key. This license key is used for access to theme upgrades and support.
    A field appears and Save API Key.

    Any idea if the API Key is the root to the issue above or is it just that I have WP 3.3.1 and plugin can’t be used?

    http://wordpress.org/extend/plugins/styles/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author pd

    @pdclark

    It sounds like you might be experiencing a Javascript conflict. Does temporarily disabling all plugins resolve the issue? Did you install any new plugins recently? Is javascript enabled?

    Thank you for your patience in helping me find a solution to your problem.

    I havent tested to disable all other plugins and yes I have recently loaded some new plugin as I have acually started to use WP and was looking after some style plugins which could help easily to change settings. I checked javascript consol and there I notice that most of your file was denied for some reason that I cant understand.

    I will test your plugin stand-alone and see if it will work.

    Will come back asap tonight.

    Per

    Plugin Author pd

    @pdclark

    Okay, thanks. Try changing permissions to 755 instead of 766, and try disabling other plugins.

    I have now tried to disable all plugins but still same issue and now I can click on the settings, API key-field is empty dont know it should be that?

    Regarding char mode, which folder should I set with 755, styles?

    Ok now I have tested to set styles folder with 755 and all plugin disabled still same issue. But after I cleaned out all cache and history from browser and updated I get your plugin up and running. But I have got that before a short while and then after some time (might be conflict with some other plugins) its stop working. So its not stable for me to use or trust.

    I will try now to activate plugin one by one and see if I can see any affect on your plugin after each activations.

    I will come back soon again.

    Per

    Plugin Author pd

    @pdclark

    Sounds good. Once I know which plugin is causing the plugin, I can likely either change my plugin or theirs to fix whatever causes them to conflict.

    Now I have tested to activate plugin by plugin but now its seems to be working so perhps the permission was the issue here. But since I have done some unexpected changes for styles when I tested before I get all entries for post and comments not visible I assume I have chosed some settings with white colors. So I have deleted your plugin including all data. Then I noticed that deletion specified 2 row:
    Styles av Brainstorm Media (kommer även att raderas dess data)
    Styles av Brainstorm Media (kommer även att raderas dess data)

    Can it be that your plugin in some sence has been duplicates even if I only had 1 folder called styles?

    I will try now to recreate folder styles in plugins with 755 and re-install your plugin again.

    Plugin Author pd

    @pdclark

    Possibly, if you tried to install manually. There should only ever be one version if you installed with the built-in WordPress plugin installer and default permission settings.

    Ok, will the built-in installer create the styles folder into the plugin folder, I belive it didnt last time I installed it?

    Plugin Author pd

    @pdclark

    It only wouldn’t if the installer said Installation Failed. (The plugin can’t exist or run from anywhere else).

    Ok, Now I have re-install it after deletion and I notice following issue:

    1. All text in my post and comments are colored with white ( text not visible).
    2. Tried to change the color to black but now I got the error:
    “Could not write to /wp-content/uploads/styles/cache.css directory.
    CSS has been cached to the database instead. This can be changed by making the directory writable with chmod 666″
    3. I checked styles folder and it has actually 755 as rest of the folders

    So I think this is not so 100% stable or what can the issue be?

    I tested to save once more after the above error around 666 and now it got saved with this msg:
    Stylesheet rendered and cached to /wp-content/uploads/styles/cache.css.

    Plugin Author pd

    @pdclark

    1. You probably selected white as the default text color. Check the font settings, especially in the “General” section.
    2. This is a notification, not an error. It’s just telling you that Styles wasn’t able to write a cache file to your server, so it wrote a cache file to your database instead. It detected your settings and picked the second-best option for you. No error occurred.
    3. The path your found in your second message, uploads/styles, is the correct path you would want to set permissions on, not plugins/styles. Again, this is optional. It’s just if you want the cache to be to a file you can read instead of the database.

    Ok then we might be up and running then!!

    Plugin Author pd

    @pdclark

    Great. I’m glad we could get it sorted out for you.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] [Plugin: Styles] Some bugs?’ is closed to new replies.
Skip to toolbar