Support » Plugin: Cloudflare » Plugin strips http(s) from the canonical URL

Viewing 6 replies - 1 through 6 (of 6 total)
  • FYI: I have deactivated HTTPS Protocol Rewriting on the 2 sites I mentioned as examples.

    Please drop us a line to CloudFlare support so we can investigate and/or file a ticket with our developer.

    Same happened to me. Had to discontinue using flexible https, can’t afford to have canonicals screwed up.

    When cloudflare rewrite https is Off, site is acting weird anyway: first time I load front-end page from https://, it have everything including canonical link with “https://”, even though my site url is set to http.

    Way too raw and brittle for a production usage, for my taste.

    I am seeing the same issue, I remember this being fixed though. Found this original thread where it was fixed, maybe the fix broke with the last release?

    @dfritsch — version 1.3.16
    https://wordpress.org/support/topic/https-protocol-rewritting-not-for-canonical-urls?replies=11

    I’m wondering if this is related to the issues I was having until I disabled https protocol rewriting. Password protected pages simply wouldn’t load. Would just go back to the password dialog box.

    Is any work being done on this issue?

    It doesn’t matter if I enable or disable the HTTPS rewriting option in the plugin settings, I always get a redirect loop error.

    I’m trying to enable HTTPS for WooCommerce checkout pages. I enabled HTTPS for this via the WooCommerce settings.

    It simply doesn’t work. As soon as I hit the checkout button on the shopping cart, it’ll stall for about 10 seconds then give me the redirect loop error.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Plugin strips http(s) from the canonical URL’ is closed to new replies.