Support » Plugin: Strictly Google Sitemap » [Plugin: Strictly Google Sitemap] Missing backslash when enabling Categories

  • Resolved ScrewedDK


    First I would like to say thanks for good sitemap generator.
    I havde found a couple of issues. It seems that when I enable categories to my build options it generate the path without a backslash after .com, .dk, and so on. It means that google can’t use those paths. Is it a bug, or can I change it in a setting?

    Further it seems that custom pages isn’t working for me. I tried to manually add my categories, but they didn’t show up when i generated the sitemap.

    Help is appreciated. 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • Agree, this is superior to what I was using if only I can correct this isssue.

    I am having the same issue with my 3 sites (two different servers) & tags don’t work either.



    Please help!

    Plugin Author Strictly Software


    I have fixed this problem which seems to have started after WordPress 3.0 came out.

    I don’t know why it was only affecting the permalink structures for category and tags and not posts, pages, author or archives but it for some reason it was which is why you were getting URL’s like


    and not

    The issue with %post_tags% was also similarly related and should be fixed now as well.

    Also the custom pages code should be working now as well. As long as the format is correct then they should be outtputed at the end of the sitemap.

    Anyhow if you download version 1.0.7 then all these problems should be fixed ( I tested it with both build methods on my own system and it worked)

    I don’t know how long it will take WordPress to update but the subversion repository should have the updated version in the trunk.

    Thanks and remember if you really do like my plugin and think it’s superior to anything you have used so far then there is a donate button at the bottom of the admin page 🙂

    Great news! I’m happy to donate once I can put it into production on my sites.

    Where can I download 1.07? The WP site has 1.06 and your site has 1.05.

    Does this also address the search engine ping with cron and the qzip file length issue?

    Many thanks!
    – WCC

    Plugin Author Strictly Software


    This issue seems to be related to changed WordPress has made to their codebase since 3.0.1 (not sure which release but 3+)

    The permalink structure for their tag posts used to be /tag/%tag% where %tag% was replaced with the post tag in question however for some reason they have changed this to /tag/%post_tag%/

    Therefore as my plugin doesn’t rely on core WP code to return formatted permalinks on version 3.1 this would have caused an issue.

    Users need to know that my plugin has been designed totally differently from the others out there which are mainly based on loops through each data set (posts,pages,tags,categories etc) and for each record more function calls are made to get permalink structures and then the necessary related categories,tags,author names etc to parse the permalink with.

    My plugin has taken a totally different tact and to try and increase performance, lower DB calls, reduce loops and memory usage etc it bypasses a lot of the standard wordpress functions and returns the data straight from the database (pushing the load from web to DB). This is why with other plugins the more records you output the more DB calls are made whereas with my plugin the no of DB calls remains the same >> read this plugin performance comparison.

    Therefore when WP change things like the format of their core permalink structures (which shouldn’t happen often) the code will need updating.

    Some people may see this as a design issue other may not. If you don’t like this way of doing things then there are plenty of other sitemap plugins out there that do things differently 🙂

    By the way I am not complaining at the two posters above just making a general point to future readers in case they experience similar or future problems.

    Anyway this was the cause of the issues to do with missing slashes and %post_tag% appearing in the sitemap.

    Plugin Author Strictly Software


    So I take it that you are happy now that I have fixed all these problems for you? It’s just that I notice you are still using the plugin on your production sites, there are no issues with placeholders and the GZIP is working correctly but I haven’t received the donation you said you were happy to make 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Strictly Google Sitemap] Missing backslash when enabling Categories’ is closed to new replies.