WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Stray Random Quotes] Extra number after using stray quotes shortcode

[Plugin: Stray Random Quotes] Extra number after using stray quotes shortcode

  • Am seeing the number 1 appear after the quotes and I would rather it not appear. Not sure why it does at all.

    Have checked my code, and I don’t think it’s on my end. Have wrapped the quotes in a div, and indeed, the 1 appears within the div.

    Here is the shortcode I’m using:
    [stray-all categories="some-category-name"]

    Any ideas what would cause the #1 to appear after the quotes?

    http://wordpress.org/extend/plugins/stray-quotes/

Viewing 5 replies - 1 through 5 (of 5 total)
  • No one else?

    On a hunch, I added some code to the end of the author field, then removed it and strangely the number 1 disappeared!

    Problem solved! err sorta 😛

    Actually disregard that last comment.

    Have found what it is though… it’s the page number for the quotes!

    Apparently, even if there is only 1 page, the number 1 appears beneath the quotes.

    If the dev is reading this, would appreciate an option to disable that; looks pretty silly when there is only 1 page of quotes!

    I was having this problem too. Your page number suggestion really helped. To prevent this from printing comment out this line $loader = $first . $prev . $nav . $next . $last; in stray_functions.php Hope that helps.

    Yeah, made a similar change, but I actually like the page functionlity, just not on quotes that only fill 1 page. If it helps, changed that line to:

    if ($pages > 1) {
    	$loader = $first . $prev . $nav . $next . $last;
    }

    Just don’t like modifying other’s plugins as I’ll lose the changes on upgrade to the next version. Dev, if you’re reading this, maybe integrate the above?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Stray Random Quotes] Extra number after using stray quotes shortcode’ is closed to new replies.