Support » Plugin: WordPress Popular Posts » Plugin Stopped working in Sidebar

  • Resolved vickigarside


    Hi there

    The plugin has been working fine up until the last week or so. I haven’t changed anything in my settings but it has stopped working and shows “Sorry. No data so far.” in my sidebar.

    (My setting are 3 posts, by total views in the last 7 days and type ‘posts’ taxnomy ‘category’ – display post thumbnail – and have tried sele 90×90 as an option from the drop down and set size manually 90×90)

    Is this a known issue following the wordpress update? Do I need to change any settings to make it work again?


    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Héctor Cabrera


    Hi @vickigarside,

    It seems one of your plugins is either removing WPP’s tracking script or it is being bundled in a location that prevents it from being run.

    If you’re using a caching plugin clearing/flushing its cache might solve the issue. If that’s not the case, then please:

    1. Go to Settings > WordPress Popular Posts.
    2. Append &tab=debug to the URL in the address bar of your browser and hit Enter.
    3. Copy the information displayed in the Debug screen and share it here so I can have a look.


    Thank you Hector

    Clearing the cache didn’t fix it.

    Here’s the info from the debug screen:

    WordPress Popular Posts

    PHP version: 7.0.27

    PHP extensions: Core, date, libxml, openssl, pcre, sqlite3, zlib, bz2, calendar, ctype, curl, hash, filter, ftp, gettext, gmp, SPL, iconv, pcntl, readline, Reflection, session, standard, shmop, SimpleXML, mbstring, tokenizer, xml, cgi-fcgi, bcmath, dom, fileinfo, gd, imap, intl, json, exif, mcrypt, mysqli, PDO, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, Phar, posix, soap, sockets, tidy, xmlreader, xmlrpc, xmlwriter, xsl, zip, ionCube Loader

    Database version: 5.6.23-cll-lve

    InnoDB availability: DEFAULT

    WordPress version: 4.9.2

    Multisite: No

    Active plugins: All in one Favicon 4.6, Autoptimize 2.3.2, Cloudflare 3.3.2, Disable Emojis 1.7, EasyAzon – Amazon Associates Affiliate Plugin 4.0.19, EasyAzon Pro 4.0.17, Easy Facebook Likebox 4.3.5, EWWW Image Optimizer 4.0.6, Fantastic Copyright Free 2.3, Fix Structured Data Errors 1.0.0, Genesis Columns Advanced 2.0.3, Heartbeat Control 1.2.2, Insert Headers and Footers 1.4.2, Lazy Load 0.6.1, Leaflet Maps Marker 3.12.1, MailChimp for WordPress 4.1.14, Mediavine AMP Redirect 1.0.0, Mediavine Control Panel 1.7.5, Optin Forms, Pretty Links 2.1.3, Redirection 2.10.1, RICG Responsive Images 3.1.1, Shareaholic | share buttons, analytics, related content 8.6.1, Simple Author Box 2.0.2, Simple IP Ban 1.3.0, Smart Slider 3 3.2.12, Social Media Feather 1.8.4, SSL Insecure Content Fixer 2.5.0, Sucuri Security – Auditing, Malware Scanner and Hardening 1.8.11, Table of Contents Plus 1601, TablePress 1.9, TinyMCE Advanced 4.6.7, Triberr 4.0.8, UpdraftPlus – Backup/Restore 1.14.2, Video Embed & Thumbnail Generator 4.6.20, WordPress Popular Posts 4.0.13, WP-DraftsForFriends 1.0.2, WP-Optimize 2.1.1, WP-SpamShield 1.9.21, WP Fastest Cache, WP Sitemap Page 1.6, Yoast SEO 6.1.1

    Theme: Sela (1.0.15) by Automattic

    Plugin Author Héctor Cabrera


    Thanks @vickigarside!

    Alright, please try this:

    1. Go to Settings > Autoptimize and click on Show Advanced Settings.
    2. Under JavaScript Options, add wpp.js to “Exclude scripts from Autoptimize” to prevent Autoptimize from bundling it with its cached scripts.
    3. Click on Save Changes and Empty Cache.
    4. Go to WP Fastest Cache > Cache Timeout and make sure you have a rule in place that deletes all cached files every 10 hours. This is to make sure WPP is able to track your visits properly by keeping WPFC from caching an invalid security token for too long.
    5. Finally, go to Delete Cache and click on Delete Cache and Minified CSS/JS to rebuild your site’s cache so all the changes made in the previous steps are reflected on your site.

    If everything went fine, WPP should be able to track visits to your site now.

    To make sure, try visiting your site using a different browser or by navigating in Incognito Mode and then check one of your posts – like the one you linked in the OP for example. You should see that visit reflected in WPP’s Stats section right away.

    Please keep me posted with the results, OK?



    Hi Hector

    That worked – thank you!

    Plugin Author Héctor Cabrera


    Awesome, thanks for reporting back! I’m glad to know everything’s back to normal 🙂

    Enjoy the plugin!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.