Support » Plugin: MaxiCharts » Plugin Stopped Working After Update

  • Resolved radumcristian

    (@radumcristian)


    Hello!
    I was using MaxiCharts with Gravity Forms and after doing some research, I finally made the plugin to display the information I needed.
    Everything went nice and smooth but i got a plugin update and after updating the plugin the charts are not displaying anymore.

    This problem occurs when i try to create new charts also , i was using the feature from the text editor and i also used a manual input and none of them really works.

    Example of code that worked before update: [gfchartsreports gf_form_id=”1″ include=”7″ type=”pie” colors=”#50e0aa,#163a28″ color_rand=”0″ height=”200″ tooltip_style=”BOTH” position=”float” case_insensitive=”0″ chart_js_options=”title: {display: false}” filter=”0″/]

    Could you guys please tell me what is happening ? i find this info really useful and unfortunately it stopped working . best regards!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author maxicharts

    (@maxicharts)

    Hi @radumcristian,

    Can you please send us the log file located under maxicharts/logs/
    Using our contact form : https://maxicharts.com/contact/

    Thanks

    Plugin Author maxicharts

    (@maxicharts)

    You can also easily test : remove parameters one by one, and see when it works.

    I have tried to test it using the default values, i also tried to remove parameters one by one and still without success, I already mailed the logs, hoping that there is a easy fix for this issue.

    Plugin Author maxicharts

    (@maxicharts)

    I can see a strange defer attribute, not coming from maxicharts, but added (by third party code?) to script import:

    <script type=”text/javascript” src=”https://nostracryptos.com/wp-content/plugins/maxicharts/libs/chartsjs/2.7.2/Chart.min.js&#8221; defer=”” ‘=””></script>

    Can you try removing this extra parameter so does the Charts script gets included correctly ?

    Hello Sir, could you please tell me what file exactly should i update? i also disabled all plugins for caching and minimizing/defering the js. thanks!

    Plugin Author maxicharts

    (@maxicharts)

    If you leave only maxicharts plugins activated and refresh your browser cache, does it work correctly?

    I have disabled all the plugins except maxicharts, gravity view and gravity forms, opened a incognito instance of chrome , tested to see if the plugin displays the charts or if is interfering with other plugins and still no output 🙁 i also tested this on a different laptop to make sure this issue is not from my computer/browser

    Plugin Author maxicharts

    (@maxicharts)

    Do you still have errors in console saying it cannot load Chart file ?

    Plugin Author maxicharts

    (@maxicharts)

    It says : “Uncaught ReferenceError: Chart is not defined”
    which means the file hasn’t been loaded probably

    Yes, i can see this error showing in the console , it shows for the existing charts i created but it also showing the same for new charts that i create .

    The form has 47 entries, i checked into them to make sure the information is correct and the chart uses the correct parameters.
    I also created a new entry now , created a test chart to read that entry but still showing the same error. i can’t even diagnose the problem because i have no idea if this is due to a newer gravity forms update or something else.

    Plugin Author maxicharts

    (@maxicharts)

    Can you activate WP_DEBUG in order to send me the debug.log file after testing please ?

    https://codex.wordpress.org/WP_DEBUG

    Plugin Author maxicharts

    (@maxicharts)

    Still the “defer” parameter when all plugins disabled ?

    I did activated the wp debug feature, when i go to a blank page to create a new charts here’s the error i receive:

    Notice: Undefined variable: columns in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 706 Notice: Undefined variable: rows in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 707 Notice: Undefined variable: header_size in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 714 Notice: Array to string conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 656 Notice: Array to string conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 656 Notice: Undefined index: data_conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts/mcharts_data_conversion_plugin.php on line 144 Notice: Undefined index: list_field_id in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 1150

    maxicharts.php , on line 706 there is the following code: MAXICHARTSAPI::getLogger ()->debug ( $columns ); — on line 707 there is the following code: MAXICHARTSAPI::getLogger ()->debug ( $rows ); —- on 714 there is the following code: $header_size = str_replace ( ‘ ‘, ”, $header_size );

    mcharts_gf_source_add_on.php , on line 656 there is the following code: self::getLogger()->debug($form_id . ‘ – ‘ . $search_criteria . ‘ – ‘ . $sorting . ‘ – ‘ . $paging);

    mcharts_data_conversion_plugin.php , on line 144 there is the following code: $data_conversion = $args[‘data_conversion’];

    maxicharts.php , on line 1150 there is the following code: } else if (
    !is_numeric($atts[‘list_field_id’]) && isset($multiRows) && $multiRows

    and this is the error in the backend of the page:

    Notice: Undefined variable: source in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 146 Notice: Undefined variable: destination in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 146

    code on line 146: self::getLogger()->trace(“Admin page for shortcode gfchartsreports : ” . $source . ‘ -> ‘ . $destination);

    and this is the debug output from my initial page where the charts worked before:

    Warning: array_key_exists() expects parameter 2 to be array, boolean given in /home/nostracr/public_html/wp-content/themes/Divi/includes/builder/functions.php on line 1827 Notice: Undefined variable: columns in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 706 Notice: Undefined variable: rows in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 707 Notice: Undefined variable: header_size in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 714 Notice: Array to string conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 656 Notice: Array to string conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 656 Notice: Undefined index: data_conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts/mcharts_data_conversion_plugin.php on line 144 Notice: Undefined index: list_field_id in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 1150 Notice: Undefined variable: columns in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 706 Notice: Undefined variable: rows in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 707 Notice: Undefined variable: header_size in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 714 Notice: Array to string conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 656 Notice: Array to string conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 656 Notice: Undefined index: data_conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts/mcharts_data_conversion_plugin.php on line 144 Notice: Undefined index: list_field_id in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 1150 Notice: Undefined variable: columns in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 706 Notice: Undefined variable: rows in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 707 Notice: Undefined variable: header_size in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 714 Notice: Array to string conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 656 Notice: Array to string conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 656 Notice: Undefined index: data_conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts/mcharts_data_conversion_plugin.php on line 144 Notice: Undefined index: list_field_id in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 1150 Notice: Undefined variable: columns in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 706 Notice: Undefined variable: rows in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 707 Notice: Undefined variable: header_size in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 714 Notice: Array to string conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 656 Notice: Array to string conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts-gravity-forms-source-add-on/mcharts_gf_source_add_on.php on line 656 Notice: Undefined index: data_conversion in /home/nostracr/public_html/wp-content/plugins/maxicharts/mcharts_data_conversion_plugin.php on line 144 Notice: Undefined index: list_field_id in /home/nostracr/public_html/wp-content/plugins/maxicharts/maxicharts.php on line 1150

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Plugin Stopped Working After Update’ is closed to new replies.