Support » Plugin: WP Activity Log » Plugin Stopped working after latest update

  • Resolved rick435

    (@rick435)


    Plugin stopped working and disappeared from Plugin List after latest update. I deleted it through FTP and when I try to reinstall I get a “sorry, you are not allowed to access this page” message.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m in exactly the same boat as rick435. Tried to remove entries in relevant wp table as per an earlier support message and the table was already empty.

    Plugin Contributor robertabela

    (@robert681)

    Hello @rick435 and @qddesign

    Thank you for using our plugin. I am sorry to read about your problem. We have an easy fix for you.

    In the latest update we moved all the plugin’s settings from a custom options table to the default WordPress options table, to boost performance. And in some cases the settings are not migrated properly and it seems this is what happened in your case.

    Can you please delete the setting wsal_restrict-plugin-settings from the wp_options table? This is a setting used in version pre 4.1.3 and unfortunately in some cases the plugin is unable to delete it during the upgrade process.

    That should do the trick. Please do not hesitate to get in touch if you have any other questions.

    Thanks @robert681 That sorted it!

    For anyone else finding this, delete the setting in the wp_options table, uninstall the plugin and reinstall / reactivate. It even found the log files from before it went awry.

    Plugin Contributor robertabela

    (@robert681)

    Glad all is sorted @qddesign

    Should you have any other questions do not hesitate to get in touc. Can you please rate our plugin and service here: https://wordpress.org/plugins/wp-security-audit-log/#reviews ? These reviews really help us.

    Thank you very much and have a great day.

    Thread Starter rick435

    (@rick435)

    I deleted the settings and the log appeared, but it is still not appearing on my plugin list. I’ve deleted, reinstalled and activated. nothing. (and I’ve had some users say they’re experiencing timeout errors when accessing the site, not sure if it’s related.)

    Plugin Contributor robertabela

    (@robert681)

    If the plugin is not appearing in the list of installed plugins is because you or someone from your team have enabled the feature to hide it from the list.

    You can revert that setting. Navigate to the plugin’s settings and set the setting Hide Plugin in Plugins Page to NO.

    This should do the trick. Please let us know if you require any further assistance.

    Hello

    I tried this but I’m unable to delete the key.
    I can only click on the key and then put something in the text box but I cannot completely remove it.

    Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    Hello @tuurherm

    I am sorry, but I do not know what you are referring to. Can you please open your own thread and elaborate more on the issue?

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin Stopped working after latest update’ is closed to new replies.