WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Stop Spammer Registrations Plugin] I'm the Admin and it detected me as a spammer and l

[Plugin: Stop Spammer Registrations Plugin] I'm the Admin and it detected me as a spammer and l

Viewing 15 replies - 1 through 15 (of 25 total)
  • Whatever it was…
    I suggest you log into your blog again, install and activate the plugin then go check the history and find out why it blocked you…

    Most probably you were using an IP that was previously used by spammers…

    Plugin Author kpgraham

    @kpgraham

    I know and I’m trying to figure it out.

    I will have a 3.1 version up in a few hours if I can figure it out.

    Keith

    Plugin Author kpgraham

    @kpgraham

    Ovidu,

    It seems to be real. Something changed overnight. I am investigation. StopForumSpam shows in Google as COMPROMISED, which may be part of the issue.

    Keith

    Thanks!
    I have deactivated StopForumSpam for now until you give the green light 🙂

    To do this I these options:
    Deny spammers found on Stop Forum Span with more than 9999 incidents, and occurring less than 1 days ago.

    And then purged the cache!

    Maybe you should post this in all relevant threads so users stop fretting?
    I know I have weakened my protection but this is better than disabling the whole plugin!

    Plugin Author kpgraham

    @kpgraham

    SFS reports IP checks with 255 days. This seems to be an error.

    If you reset the number of 999 incidents and occurring 1 then it works

    Keith

    Plugin Author kpgraham

    @kpgraham

    Version 3.1 works now.

    Please reinstall the plugin and test it.

    I am still not sure why it suddenly started failing. It has to do with StopForumSpam.com reporting all ip checks with an email as spam.

    Keith

    Is a reinstallation necessary?
    I simply overwrote the previous version with 3.1 and it seems fine.

    Plugin Author kpgraham

    @kpgraham

    If anyone has uninstalled 3.0 and deleted, then reinstall is necessary.

    If it is just deactivated then updating 3.1, either by copying code, or using the WP updater will get the new version. Then activate.

    Keith

    I updated and re-activated. Here’s a screenshot of my log where my IP was the one logged: http://ScrnSht.com/abrxtd

    One thing I noticed is that the time zone is not the one I have set in WP Admin options. That might be something to improve — either point out that it’s UTC or use WP’s time zone settings.

    Thanks for the fix.

    Plugin Author kpgraham

    @kpgraham

    Thanks for the screen shot. You can see where SFS rejected you with a frequency of 255. I don’t understand it.

    I am very annoyed by the time zone thing and it is time to fix it. It is using zulu time (greenwich), so I’ll see about changing it.

    Keith

    I thought everything was ok since I was on the newest version, but it did it again. The “Cached bad ip” error… And my IP is in the list of “Rejected IPs” even though http://www.stopforumspam.com/search?q=_my.ip_ shows 0 entries. Deactivated again, hopefully not forever…

    Plugin Author kpgraham

    @kpgraham

    You need to clear the cache to get your IP out of there.

    Keith

    You can add your ip to the white list and it’s working. I had same problem, after the update, I was seen like a spammer, and I don’t know why. I’ve checked my ip with all the spam websites, and it’s not there. After I added to the white list, everything works very fine.

    Plugin Author kpgraham

    @kpgraham

    3.2 version which will release soon automatically adds you to white list. It also fixes the problem with false positives on SFS. It adds lots of new known spammer IP ranges and also checks with Akismet.
    I will not release it just yet. It needs lots more testing.

    Keith

    Help – I cannot access my blog. I have deleted the plugin via ftp, but still cannot get in…

    Has anyone got back in? Please explain how.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Plugin: Stop Spammer Registrations Plugin] I'm the Admin and it detected me as a spammer and l’ is closed to new replies.