WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Stop Spammer Registrations Plugin] History and Cache page still not available in 3.2

[Plugin: Stop Spammer Registrations Plugin] History and Cache page still not available in 3.2

  • wadams92101
    Participant

    @wadams92101

    I haven’t been able to access my Stop Spammers history and cache since at least 3.1. I saw the previous forum post by the user who had the same problem, and your response that it would be resolved in 3.2. However, after upgrading to version 3.2 I still get a 404 error message: “The requested URL /wp-admin/network/options-general.php was not found on this server.” Via FTP, I don’t see such a file either in wp-admin or in the plugin folders. Any suggestions?

    http://wordpress.org/extend/plugins/stop-spammer-registrations-plugin/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author kpgraham
    Participant

    @kpgraham

    You should access the plugin from the settings menu. If you have a non-standard network install the link on the dashboard might not work. (I am trying to resolve this).

    If you can’t access the plugin from the settings menu, you can try uninstalling the plugin and reinstalling it.

    You should go your plugins page and uninstall and delete the plugin so you can start over.

    Log in as a network administrator and go to your network plugins page and install it from the add new plugin link and let wordpress download it from wordpress.org.

    Network activate the plugin and you should be good. Use the link on the settings menu to access the plugin.

    Please report back here if you can get into the settings.

    Keith

    wadams92101
    Participant

    @wadams92101

    Hi Keith, thanks for great plugin and great support. However, I tried the above and it didn’t work. I am able to access the plugin via the settings link. I deactivated, deleted it, and reinstalled from the repository via WP Add New. Still no access to history and cache. The only quirk was that it wouldn’t uninstall via WP admin so I had to delete via FTP. I other plugins uninstall fine. Your thoughts?

    Plugin Author kpgraham
    Participant

    @kpgraham

    From what you are saying, you can access the history and options through the settings links, but can’t access it through the link on the dashboard.

    I fixed a bug in 3.2 which prevented WPMU users going directly to the options page if it was not installed as a network plugin.

    Please right click the link that doesn’t work and “copy link location” (Firefox) or “Copy Shortcut” (IE) and then paste that in a reply here. Do the same for the link that does work. I can then compare the one that doesn’t work to the one that does and maybe figure out what the problem is.

    If you use FTP to install the plugin make sure that the “includes” folder is copied, too.

    There may also a “sfs_debug_output.txt” file in the same folder as the plugin if you had any errors. Most errors are not really problems, but there may be something new if the plugin has detected anything.

    Keith

    wadams92101
    Participant

    @wadams92101

    Hi Keith, thank you for the speedy response. This is a WP MUltisite and the plugin is network activated. I cannot access the history and cache via settings>Stop Spammers. When I click on the link in the settings, that is when I get the errors message. I don’t see an alternative way of looking at the cache and history. There is no link in the dashboard, as far as I can see. I looked for the sfs_debug_output.txt file you mentioned and didn’t see that anywhere. Further thoughts?
    Bill

    Plugin Author kpgraham
    Participant

    @kpgraham

    Have you tried from both the network dashboard and the dashboard for the main blog.

    Blog #1 is the first or “home” blog. Perhaps you can access it from there.

    Do you use subdomains? Perhaps something is going on with the subdomains.

    Keith

    wadams92101
    Participant

    @wadams92101

    Hi Keith, I never new I could access it from the main blog in addition to the network admin. (Yes I use subdomains) But there it is Settings>Spammer History with its own separate link for the history. Awesome! Sorry to be a nuissance when it was under my nose the whole time. I guess I was just used to the old version where I accessed from the network admin settings>stop spammer reg admin area. Anyway, problem solved as far as I’m concerned. (Reminder to self, donate before weekend is out) Thanks again for a one of a kind life saver plugin!!!

    Plugin Author kpgraham
    Participant

    @kpgraham

    Wadams,

    It is still a problem as to why it is not working on a subdomain blog.

    I will research this.

    There is a bugfix release any minute now. I want this fix in it.

    Keith

    wadams92101
    Participant

    @wadams92101

    Hi Keith, it works from the subdomain blog admins. Its just not working from the Network Admin.

    Plugin Author kpgraham
    Participant

    @kpgraham

    I will try to fix it so that all links are to the first subdomain blog.

    Keith

    Plugin Author kpgraham
    Participant

    @kpgraham

    int version 3.3, I have used a different WordPress call to find the plugin admin page. I am hoping this works with subdomains.

    Please report here if it still does not work.

    Keith

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Stop Spammer Registrations Plugin] History and Cache page still not available in 3.2’ is closed to new replies.