StatPress Visitors
[resolved] no data after update (15 posts)

  1. evilkalah
    Posted 3 years ago #


    i'm using the version after last week updates no new data is added anymore. Don't really know where to search.
    I deactivated/actived the plugin again
    i clicked on update the database select all and execute that.

    Any ideas?



  2. evilkalah
    Posted 3 years ago #

    this is a describe of the statspress table

    id mediumint(9) unsigned NO PRI NULL auto_increment
    date int(8) unsigned NO MUL NULL
    time char(8) YES NULL
    ip varchar(39) YES NULL
    urlrequested text YES NULL
    agent text YES NULL
    referrer text YES NULL
    search text YES NULL
    os tinytext YES NULL
    browser tinytext YES NULL
    searchengine tinytext YES NULL
    spider tinytext YES NULL
    feed tinytext YES NULL
    user tinytext YES NULL
    timestamp int(10) unsigned NO NULL
    language varchar(3) YES NULL
    country varchar(3) YES NULL
    realpost tinyint(1) YES NULL
    post_title tinytext YES NULL

  3. luciole135
    Plugin Author

    Posted 3 years ago #

    The data table is correct, there is no reason it does not record anything unless your WordPress is corrupt.

  4. evilkalah
    Posted 3 years ago #

    i have 6 wordpress website's, at 15 augustus i had every day a warning about a new patch of StatPress Visitors. i installed it every time.

    And all 6 standard, not modified wordpress website's are having problems with the statspress visitors not working anymore.

    Would be strang if all 6 are corrupt on the same timestamp.

    Could you have a second look please? or are there things you need to have a second opinion?


  5. luciole135
    Plugin Author

    Posted 3 years ago #

    Watch with phpMyAdmin if you have records of visits to the data table statpress.
    It's really weird that nothing works because the data collection is done without using javaScript, and therefore must operate.

  6. Blackbam
    Posted 3 years ago #

    Why is this problem marked as resolved, I cannot find a solution here? I have the same problem, StatPress Visitors just stopped collecting any data.

    What can be the reason for this?

  7. luciole135
    Plugin Author

    Posted 3 years ago #

    Watch with phpMyAdmin in your datatable statpress if StatPress Visitors stopped to collecting data.

  8. Blackbam
    Posted 3 years ago #

    Yes, StatPress Visitors stopped collecting data.

    After deactivating and reactivating the Plugin, a message like "StatPressV table updated" was displayed. Now it is collecting data again, but I have a lack of 5 days (for me thats not a problem).

    Thank you for the Plugin and keep up the good work.

  9. Innt
    Posted 3 years ago #

    I seem to be having the same problem.
    After update to yesterday Statpress V is no longer working.
    When looking at the tab latest visitors nothing shows up although all other tabs seem to be working fine. The table in the database does not get any new records at all since the update. Trying to update the tables with definitions doesn't work either. When selecting one or all options and a random timeperiod the browsers just stays on "updating" indefinately.

    Please some suggestions as to how to get this working again (I tried deactivating and activating several times already) or how to do a reinstall with data collected thusfar saved?


  10. Innt
    Posted 2 years ago #

    In regards to my previous post:

    If Evilkalah's table is correct that probably means mine has never updated when I updated to since my table has the following fields:

    id mediumint(9)
    date char(8)
    time char(8)
    ip tinytext
    urlrequested text
    agent text
    referrer text
    search text
    os tinytext
    browser tinytext
    searchengine tinytext
    spider tinytext
    feed tinytext
    user tinytext
    timestamp tinytext
    language varchar(3)
    country varchar(3)

    Is there a way to manually trigger the updatescript so the table will be updated as seems necessary?

  11. luciole135
    Plugin Author

    Posted 2 years ago #

    Your datatable is not correct may be it's your WordPress who is corrupted.

    Re-install WordPress.

  12. Innt
    Posted 2 years ago #

    Reinstalling WP is not an option given the content of the website and the history I need to preserve. Apart from that, WP is running flawless. No problems with whatever part of WP whatsoever so it's not WP but your update that did not update the table (correctly).

    I am sure the update of the table is part of a script somewhere that uses SQL to update the table and possibly the contents. Point me to where to find this script and I'll try to run it or mimic it's working manually?

  13. luciole135
    Plugin Author

    Posted 2 years ago #

    It is very easy to reinstall WordPress, simply proceed as for an update but with the same version.

    Updating of the data table is made in the file with the function statpress.php StatPressV_activate which is called each time the plugin.
    If this does not focntionne at you is that your WordPress is corrupt.

  14. evilkalah
    Posted 2 years ago #

    Hello Innt,

    the problem with this statspress is solved on 1 wordpress site. I did the following. I removed the plugin and installed an older one i had on hard disc. This one is working fine. Luciole135 is always telling it is the wordpress site that is corrupt but it is the statspress itself.


  15. Innt
    Posted 2 years ago #


    Hi Chris,

    thanks for replying! :) and yes, I know. It's like you renew the windshieldwiper on your car and it doesn't wipe as well as expected, you go to the store that sold you the wiper and the store says: "car broken, get a new car" :)

    I managed to solve the problem myself now though. I altered my Statpress-table so it looked like yours (3 edits in type and 2 additional fields I think) and everything seems to work normally now. Had to guess about some defaultvalues and fieldlength of one but I did it :)

    Have to say I am not a fan of the new layout. I really miss the overviewpage where all info is combined. They probably changed it for increased speed / performance but it's not really that much faster imo.

    Anyway.. my problem is solved (no thanks to liciole135) so I am out :)


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • StatPress Visitors
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.