Support » Plugin: SSH SFTP Updater Support » [Plugin: SSH SFTP Updater Support] Support for different SSH Ports?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The current version of the plugin would not even activate for me. The file sftp.php contains two fatal errors.

    Line 11 needed to be corrected from this:

    set_include_path(get_include_path() . PATH_SEPARATOR . ABSPATH . 'wp-content/plugins/sftp/phpseclib/');

    To this:

    set_include_path(get_include_path() . PATH_SEPARATOR . ABSPATH . 'wp-content/plugins/ssh-sftp-updater-support/phpseclib/');

    And line 24, from this:

    ABSPATH . 'wp-content/plugins/sftp/class-wp-filesystem-ssh2.php' :

    To this:

    ABSPATH . 'wp-content/plugins/ssh-sftp-updater-support/class-wp-filesystem-ssh2.php' :


    If you get a chance, try appending your ssh port number to the Hostname field in the connections information dialog, and see if that works for you. For example, if your non-standard port was 2345, the Hostname field would look like: ///

    Yeah, I kept trying to append my port number to the end. I never did get the plugin to work. I am just beginning to try out WordPress and installed it on my LAMP server at home. I connect to my server remotely via SSH. Ultimately, I installed the required dependencies, made keys, and altered my wp-config.php file. Now I don’t have to provide credentials to install plugins, themes, etc; I simply use SSH keys.

    The only error I ever received from this plugin was something similar to:
    There was an error communicating with the server. Please check your credentials and try again

    Enabling SSH support for php is super easy if you use a Ubuntu server. Literally, just a couple of minutes in a terminal to make it work. A touch more involved to get set it up if you use a an RHEL based system. I’ve setup both on the standard port with no wp-config editing required. Seems to work just fine (so far). 🙂

    I also had that plugin working briefly on a local install with a non-standard port before I removed it.

    [edit] I think the author may have just renamed the directory at some point and forgot to edit the sftp.php file to reflect the change. I actually think this plugin is pretty darned cool. Once the bugs are worked out, I’ll give it another go.

    Plugin Author TerraFrost


    I was able to do localhost:54321 just fine.

    Anyway, I fixed the problem with the badly named directory. ClaytonJames is right – I was testing it in my own little setup – hadn’t actually installed it from the WordPress plugin repo. I actually don’t expect many people would be installing it from the plugin repo? Seems like if you don’t have libssh2 installed but your server is only using SFTP you couldn’t use it anyway to install it.

    I guess you could have FTP and SFTP and install it initially via FTP and use SFTP for all subsequent installations for purposes of security too. I dunno lol.

    Anyway, if there are any more issues, let me know!

    Hi there,

    I use SSH & SFTP quite a lot, Vandyke SecureCRT & SecureFX, old versions from 2003 or so but great interface & the RSA1024 key pair I generated with Secure CRT 5, was accepted fine by the debian server with all standard openssh …

    Unfortunately the vandyke private key is not compatible with openssh so I couldn’t test your ssh2, which was what I wanted, I have to wait until I can convert the private key, later versions of SecureCRT can do that but it costs to upgrade.

    So I went into your standard ftp option & it said my user/password were incorrect. I double-checked with filezilla and the info was correct.
    Had to deactivate, but I like the idea so much, please carry on and meanwhile I’ll get me private key converted somehow.

    Installed yr plugin via the blog upgrade btw, automatic, said it was v1.

    Nico Morrison
    London UK

    Plugin Author TerraFrost


    Did you try to upload the key anyway? That OpenSSH doesn’t support its format doesn’t mean this plugin won’t. This plugin supports PuTTY formatted keys, XML Signature keys, etc. If the Vandyke key is unsupported you could post it?

    As for “my standard ftp option”… Do you mean “standard sftp option”? This plugin should not effect any ftp options. Maybe when you logged in with filezila you’re using FTP and not SFTP?

    As for the plugin saying v1… I need to figure out how to work with the WordPress SVN system some more lol. Not sure if I need to create a branch for that or what.

    I tried the Vandyke private key in yr plug-in with ssh2. I know from using putty that the key is not openssh compatible. Didn’t work anyway, only works with Vandyke products though connects fine with my Debian server with openssh.

    What I mean by ‘standard’ is when you go to the automatic update of a plugin & click install & a browser screen asking for ftp details comes up.

    When I activated yr plug-in it replaced that screen and since your ftp option did not work for me & I have the wrong key-type, I had to deactivate yr plug-in and then the standard screen reappeared and then I could update the needed plug-in ok.


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: SSH SFTP Updater Support] Support for different SSH Ports?’ is closed to new replies.