WordPress.org

Forums

Spectacu.la Discussion
[resolved] Strange bug with WPTouch (7 posts)

  1. MrMiyamoto
    Member
    Posted 3 years ago #

    Hello, I'm using Spectacu.la on Game Usagi and everything has been working wonderfully, but there's a smallish compatibility issue with WPTouch that makes posting comments rather difficult. Instead of having the link/quote/reply buttons under each comment they appear bunched together before the comics are shown. In addition to this, when logged in, the "post your comment" button appears on top of them, also nowhere near where it's supposed to be under the comment entry box.

    Here's a picture of the button issue: http://gameusagi.com/hotlink/photo.png

    Is there a way to fix this? Thanks.

    http://wordpress.org/extend/plugins/spectacula-threaded-comments/

  2. MrMiyamoto
    Member
    Posted 3 years ago #

    Okay, I figured it out. For anyone with the same problem, just add:

    style="position: relative;"

    Into both of the the divs that say class="comment-buttons" in the includes/functions.php file in Spectacu.la

    : D

  3. Spectacula
    Member
    Plugin Author

    Posted 3 years ago #

    Cool. Thanks. I was going to take a look it this morning.

  4. MrMiyamoto
    Member
    Posted 3 years ago #

    While you're here, there's still a small bug with my implementation. When you reply directly to a previous comment in WPTouch the "Cancel reply" button shows right on top of the "Post Comment" button.

    Here's what it looks like: http://gameusagi.com/hotlink/wptouch-bug.png

    Is there a way to stop this overlap and perhaps have the Cancel Reply button styled in the same way as the Post Comment button?

    Thanks.

  5. Spectacula
    Member
    Plugin Author

    Posted 3 years ago #

    That looks like another positioning bug much like the one before. I'll give it a look on one of my dev installs and see if I can find the appropriate thing to fix it.

  6. Spectacula
    Member
    Plugin Author

    Posted 3 years ago #

    I can't get the same problems to show up for me. However what I would advise as a better course of action would be to disable my commenting stuff on the wp-touch theme. This will reduce load on mobile devices and leave you with a touch friendly version of comments, which mine in it's default form is not. WpTouch has it's own ajax commenting so you'd not be missing out on much.

    Adding this to the top of the spec_commenting > _init method will kill spec_commenting when something intercepts the template filter.

    if ( get_template( ) != get_option('template') )
    	return;

    I've added the change to the trunk version of commenting.php which you can find here http://plugins.svn.wordpress.org/spectacula-threaded-comments/trunk/

  7. MrMiyamoto
    Member
    Posted 3 years ago #

    Thanks for the help. I ended up just disabling the "Cancel reply" button in WP-Touch. I need Spectacu.la on the mobile devices instead of the default WP-Touch comments because I've fully integrated Cubepoints including my own custom badge system with Spectacu.la and don't want to have to do it all over again with WP-Touch's comment system. Otherwise, I'm sure your suggestion would be the better option.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Spectacu.la Discussion
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic