Support » Plugin: Special Recent Posts » [Plugin: Special Recent Posts] category_title not working anymore in 1.9.7

  • Hi,

    i just upgraded from 1.9.6 to 1.9.7 and it appears that category_title=’yes’ does not seem to work anymore (there’s an href, but its blank/empty)…is that just me ?

    debug now throws following errors
    Undefined offset: 0 in [site]\wp-content\plugins\special-recent-posts\classes\class-main.php on line 805
    Trying to get property of non-object in [site]\wp-content\plugins\special-recent-posts\classes\class-main.php on line 805

    also – as a future/feature request maybe: would it be possible to have both category_title=’yes’ and widget_title=’view all (or whatever)’ so the title has the entered text , but with a link to the category (as opposed to automatically insert the title of the category regardless of the text set )

    cheers

    http://wordpress.org/extend/plugins/special-recent-posts/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Luca Grandicelli

    (@lgrandicelli)

    Well, honestly everything works fine to me. Taht line manages the post category, so it seems thee is some problem with the category assignment.
    Can you paste here the shortcode you’re using please?

    there you go

    [srp post_limit=’10’ post_date=’no’ category_title=’yes’ thumbnail_width=’50’ thumbnail_height=’50’ post_content_length=’10’ post_content_length_mode=’words’ post_order=’ASC’ category_include=37]

    or even a simple

    [srp post_limit=’10’ category_title=’yes’ category_include=37]

    Plugin Author Luca Grandicelli

    (@lgrandicelli)

    It works on every test i did. Can you please paste an url of the problem?

    i cant really, as i am developing on my own box here and its not live anywhere (yet). sorry.

    having said that, i just turned off all other plugins and activated twentyeleven theme and the problem and errormessages stay the same :(.

    the html that gets generated for the title is
    <h3 class=”widget-title srp-widget-title”></h3>

    aaarg..the code got stripped. the html is
    <h3 class="widget-title srp-widget-title"><a class="srp-widget-title-link" href="" title=""></a></h3>

    Plugin Author Luca Grandicelli

    (@lgrandicelli)

    What happens if you change category?

    (tried that)

    anyway, just for the hell of it, i have just installed a brand new copy of wordpress on my homebox here, downloaded and enabled your plugin, added
    [srp category_title=’yes’ category_include=1]
    to the sample page and there’s still no title……dunno

    Plugin Author Luca Grandicelli

    (@lgrandicelli)

    Ok, finally i got it. I’ve replicated your issue on my enviroment, but this seems to happen only within pages and not posts. Thanx for reporting this, i’ll put a fix in the next version.

    ok. as it happens , it also seems to be the case – in my situation anyway – when using the shortcode in a text widget …(although i guess if you get it to work in pages, it will also work in text widgets…just thought i’d mention it)

    cheers. glad you could replicate it and its not just me 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Special Recent Posts] category_title not working anymore in 1.9.7’ is closed to new replies.