Support » Plugin: SpeakUp! Email Petitions » [Plugin: SpeakUp! Email Petitions] button problem IE 8 and 9

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Kreg Wallace

    (@kreg)

    I think this has something to do with your domain name configuration. When I follow the link to your petition page in Firefox, the URL resolves to http://www.sønderborgkasernesvenner.dk/ but when I follow the link in IE, the URL displays as http://www.xn--snderborgkasernesvenner-lmc.dk/

    The difference between these URLs is probably what’s causing the problem. The petition form is submitted with AJAX and browsers have a built in security feature that blocks processing of AJAX scripts between two different domains. So, if your WordPress admin lives on sønderborgkasernesvenner.dk and receives an AJAX submission from xn--snderborgkasernesvenner-lmc.dk the request will be ignored.

    I don’t know why Firefox resolves the URL, but IE does not. Even when I paste http://www.sønderborgkasernesvenner.dk/ into IE, it changes it back to http://www.xn--snderborgkasernesvenner-lmc.dk/ It’s possible that IE simply doesn’t understand the ø character in your domain.

    My suggestion is to go into your WordPress admin and make sure that on the Settings > General page, the values for WordPress Address (URL) and Site Address (URL) are exactly the same. If that doesn’t fix things then look into undoing whatever domain rerouting system you have in place.

    Thank you, for your pointer,it helped a lot, have a nice day.
    BTW do you want our danish translation of the po file? + where to send?

    Plugin Author Kreg Wallace

    (@kreg)

    Sure, I’d love to have the Danish translation files. You can send them to me at: kreg [at] designkode.com

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: SpeakUp! Email Petitions] button problem IE 8 and 9’ is closed to new replies.