The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Spam Free WordPress
[resolved] HTML getting through (5 posts)

  1. Explorz
    Posted 4 years ago #

    I updated to 1.8.3 and received a license key. I use the key on three blogs. On all blogs there are two issues.

    The biggest issue is that in testing, html code gets through without being blocked. I type in a url and it posts to the blog. So, no I have blogs that are no longer protected. Basically Spam Free WordPress isn't doing what it is designed to do.

    Please help.

    The second error is that the checkboxes don't always stay checked in the settings area. I am not sure if this is related to using the Comment Form Message option or not. But saving changes often results in checkboxes showing as unchecked and I have to recheck them.


  2. Todd Lahman
    Plugin Author

    Posted 4 years ago #

    I left a test comment link using HTML on your blog at http://truenorthalliance.com/blog/bonsai-learning/, and the HTML was disabled properly by the plugin.

    The plugin does not block comments with HTML, it simply disables the HTML from working when a comment is viewed. For example, when you tested the link in a comment you may have noticed you can't click it like a link, because it is rendered as plain text, exactly as the tooltip bubble explains next to the option. Hold your mouse over the question mark, and you'll see the explanation.

    There is no reason to block a legitimate comment that uses HTML, when the plugin will render the HTML useless while allowing the comment through.

    The checkboxes not remaining checked isn't something I've seen, nor has it been reported by anyone else. The checkboxes are rendered using the Settings API which I have not direct control over. It sounds like saving the checked box works the second time, so at least it's a quirk that isn't fatal.

    I got your messages on toddlahman.com, and saw that you tried to reset your password. I added a login box, and a link to reset your password on toddlahman.com, to make it easier to use the support forum if you log out, or forget your password. Knowing you were having these issues are the reason I replied here, rather than referring you to http://www.toddlahman.com/forums/forum/spam-free-wordpress/

    Check your Junk E-Mail or Spam folder for your password reset.

    To summarize, the plugin is working exactly as it was designed.

    I hope you will give the plugin a better rating than 1 now that you understand how it is working.

  3. Explorz
    Posted 4 years ago #

    Hey Todd, Was this resolved? I'm not clear on the resolution.

  4. Explorz
    Posted 4 years ago #

    url addresses are still getting through.

  5. Todd Lahman
    Plugin Author

    Posted 3 years ago #

    The plugin doesn't block URL addresses, it does however block IP addresses if you enter them manually into the Blocklist.

    Normally WordPress converts URL addresses into a link, or it display a word with an HTML <a href="">word</a> as a link. When the plugin option "Remove Comment HTML" is checked the plugin will prevent the URL address from displaying as a link on the page, and instead displays it as plain text.

    Where did you read that the plugin blocks URL addresses?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Spam Free WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.