Support » Plugin: Spam Free WordPress » [Plugin: Spam Free WordPress] Comments post; all input boxes not formated

  • Resolved DaddyMack


    Hello Todd,
    I am new to wordpress, so this maybe me. I am running the following versions of WordPress and Spam Free.

    WordPress 3.3.1.
    Spam Free WordPress Version 1.5.1

    I followed your instrutction about channgeing the comment.php and when I did my formatting is all messed up. (see image below)

    image =

    After that did not work, I read through the post on this board and found one from rekik and tried the code you had listed for him. It helped a little, but not much.

    What can I do to fix this problem.

    I have removed the code and now you get the error about not having a password when you try to post a comment.

    website =

    theme = Academica 1.0.2 by ProudThemes

    Thank you for any or all your help,

    Daddy Mack

    ********** code from your help page ***********************

    // Do not delete these lines
    if (!empty($_SERVER[‘SCRIPT_FILENAME’]) && ‘comments.php’ == basename($_SERVER[‘SCRIPT_FILENAME’]))
    die (‘Please do not load this page directly. Thanks!’);

    if ( post_password_required() ) { ?>
    <p class=”nocomments”>This post is password protected. Enter the password to view comments.</p>

    <!– You can start editing here. –>
    <?php if (have_comments() ) : ?>
    <div class=”sep”> </div>
    <div id=”comments”>

    <h2><?php comment_type_count();?> Comments</h2>

    <div id=”commentspost”>
    <ol class=”comments”><?php wp_list_comments(‘type=all&avatar_size=40’);?>
    </div><!– #commentspost –>

    <?php else : // this is displayed if there are no comments so far ?>

    <?php if (‘open’ == $post->comment_status) : ?>
    <!– If comments are open, but there are no comments. –>
    <div class=”sep”> </div>
    <div id=”comments”>

    <h2>No comments</h2>

    <div id=”commentspost”>
    <p>Be the first one to leave a comment.</p>
    <?php else : // comments are closed ?>

    <?php if (!is_page()) { ?>
    <div id=”comments”>

    <h2>Comments are closed</h2>
    <p>Sorry, but you cannot leave a comment for this post.</p>
    </div><!– end #comments –>
    <?php } ?>
    <?php endif; ?>
    <?php endif; ?>

    <?php if (‘open’ == $post->comment_status) : ?>

    <div id=”respond”>

    <h2><?php comment_form_title( ‘Post a Comment’, ‘Leave a Reply to %s’ ); ?></h2>

    <div class=”cancel-comment-reply”><p><?php cancel_comment_reply_link(); ?></p></div>

    <?php if ( get_option(‘comment_registration’) && !$user_ID ) : ?>
    <p>You must be /wp-login.php?redirect_to=<?php echo urlencode(get_permalink()); ?>”>logged in to post a comment.</p>
    <?php else : ?>

    <?php comment_form(); ?>

    <?php endif; // If registration required and not logged in ?>

    </div><!– end #respond –>
    <?php endif; // if you delete this the sky will fall on your head ?>

    <?php if (‘open’ == $post->comment_status || have_comments()){ ?> </div><!– #comments –><?php } ?>

    ************ End of code ***********************************

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Todd Lahman


    Please post all of the code from your original comments.php file to, and I will then reply with a link to pastebin with the new code for your comments.php file.

    Here is the code

    Thank you in advance.

    Plugin Author Todd Lahman


    1. Make a backup copy of your comments.php file
    2. Go to this link,, and use the code in the “RAW Paste Data” section to replace all the code in the comments.php file.

    Hello Todd,
    I coppied the code from on Raw Paste Data and this is what it looks like now. The formatting is still messed up.

    You can see what it looks like at this image:
    And I have left the comment.php code as you corrected it, so at the site you can see how it look real time.

    Plugin Author Todd Lahman


    The problem is the theme. The look of the comment form is controlled by Cascading Style Sheets, and your theme has some big issues. For example I found the following code in the middle of your page, when it should be at the top:

    <div class="column column-narrow">
    <div class="widget"><div class="textwidget">
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "">
    <html xmlns="" lang="en" xml:lang="en">

    !DOCTYPE should come before anything else, but it is in the middle of the page.

    I suggest switching to the Twenty Eleven theme, then see how your comment form looks. You can then switch back to your existing theme if you want.

    If the comment form looks fine with Twenty Eleven then I would suggest either fixing your current theme’s CSS, to download another free theme or have a different theme designed to replace your existing broken theme.

    Hello Todd,
    The problem is that it is a paid theme, bough and paid for before I took over.
    Could I just adjust the cSS file to make this line up? If so, would you possible know what I should add?
    Thanks for your help,
    Daddy Mack

    Plugin Author Todd Lahman


    Unfortunately, the comment form CSS is only a small part of the problem with your current theme.

    Your current theme is a free download from here:

    I installed Adademica on my local debug server, and found it to be loaded with bugs, and some security holes caused by some scripts that come with the theme.

    It is no surprise you are having problems with Chrome playing your .mp3 files, but that, along with all the other theme related problems could be easily fixed.

    As a first step I recommend replacing your current theme with something more secure like Twenty Eleven, and then working to replace your current theme, since it is unusable even with a lot of work. Your current theme needs to be replaced, or preferably written by someone like myself who can write a solid theme that will continue working now and into the future.

    I am available for this type of work:

    There are also a lot of free themes available in the directory, or Twenty Eleven, that would make suitable replacements for your current broken theme. In addition to the theme work, some additional plugins are required to support some features that are currently being offered on your blog.

    The theme we have is licensed copy of Academica, and since the owners paid $100.00 for it, there is no chance of changing it.
    Now can you help me get the formatting problem corrected, or should I remove your plugin? I had planned on making a donations since you have been so helpful but changing themes is not an option. Sorry.
    Daddy Mack

    PS Thank you so much for all of your help, I really wanted to use your plugin it seems to be very good.

    Plugin Author Todd Lahman


    Spam Free WordPress doesn’t change the formatting of the comment form, since it is entirely controlled by the theme’s CSS. Since this is not a plugin problem there is nothing I can do except refer you to my recommendations regarding your theme.

    Sticking with a broken theme is a losing proposition that will continue to cause problems, but of course that is your decision.

    FYI, Spam Free WordPress is free, so no donation is necessary to get help from me, but my help is limited to the plugin itself.

    The Academica theme is free. Someone has been lying to you.

    I was just looking at this spam killer, and reading through a few posts. Todd you really are a helpful guy and you obviously know your stuff. I wondered if the OP hasn’t just gone back to the Theme creators and asked them for help as they would surely be able to sort this issue out.

    I think most people think themes are easy to make but these things take time and considering security is a primary concern, being newish to wordpress and PHP; reading up like a madman possessed, it would be nice to have a security rating on themes < copyright that Idea 😉 Although I doubt that will happen unless it kind of becomes a promotional pointer.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Spam Free WordPress] Comments post; all input boxes not formated’ is closed to new replies.