WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: SoundCloud Shortcode] Player sticks out of posts after update.

[Resolved] [Plugin: SoundCloud Shortcode] Player sticks out of posts after update.

  • Lemur
    Member

    @timsalabim

    Hello. I have been using this plugin for some time now without any problems.

    I think that after the update it started messing up, although I didnt check a few days before that, so i’m not 100% sure if its the update.

    The player suddenly sticks out on posts, its set to 100% but sticks out over the side bar. This suddenly happened yesterday or the day before, right after the update. http://lemurcattaka.com (scroll down a bit)

    http://wordpress.org/extend/plugins/soundcloud-shortcode/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author por_
    Member

    @por_

    Could you post an example of a shortcode you used?

    Lemur
    Member

    @timsalabim

    Thanks for your help

    http://lemurcattaka.com/rocco-raimundo-do-you-wanna/

    the shortcode I used is: [soundcloud url=”http://api.soundcloud.com/tracks/50795683″ params=”auto_play=false&show_artwork=true&color=000000″ width=”100%” height=”166″ iframe=”true” /]

    I doubt its the code I use though, the same players with the same code were fitting perfectly last week.

    Cheers

    Plugin Author por_
    Member

    @por_

    That does indeed look like a bug. As a quick fix; please check if the “default width” field is empty in your plugin settings.

    http://scr.timbormans.com/53cflqmusa04.png

    Lemur
    Member

    @timsalabim

    Yeah, its blank. Changing it to 50% for instance doesnt change anything.

    Lemur
    Member

    @timsalabim

    btw, do you think this happened after the update? And if so, how do I go back to a older version?

    Plugin Author por_
    Member

    @por_

    Hmm, I think I figured it out. It looks like the theme you are using has set a $content_width = 608. That overrides the default 100% because oEmbed doesn’t support percentage values. That is really shitty, but I can’t think of a good way around it right now because it’s WordPress doing this, not the plugin.

    There are 3 ways to fix it:

    1. Change the $content_width value in the functions.php of your WordPress theme to 500 (hardest fix)
    2. Change the “default width” in the plugin settings to 500 (easiest fix)
    3. Manually change the width in your shortcode (most annoying fix) [soundcloud url="http://api.soundcloud.com/tracks/50795683" params="auto_play=false&show_artwork=true&color=000000" width="500" height="166" iframe="true" /]

    I’d go with option 2. Remember you can’t use percentage values unfortunately. Let me know if that works.

    Plugin Author por_
    Member

    @por_

    Besides that I’ll try to fix it in another way and push an update soon.

    Plugin Author por_
    Member

    @por_

    I just pushed an update (version 2.2.3), for some reason I can’t see it yet, but hopefully you will get an update notification soon. This will fix your issue. In the meantime, please try one of the suggestions above. Sorry for the bug and thanks for reporting it.

    Lemur
    Member

    @timsalabim

    I just recieved the update and it’s working now. Thanks a ton!

    whoisawesomeyoureawesome.jpg

    Plugin Author por_
    Member

    @por_

    Glad it worked. Thanks again for reporting.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] [Plugin: SoundCloud Shortcode] Player sticks out of posts after update.’ is closed to new replies.