WordPress.org

Forums

Social Media Widget
Problem when widget includes in header widget (3 posts)

  1. Nozkaer
    Member
    Posted 3 years ago #

    Theme : Custom community
    Site : local (dev)

    Hello ! :)

    I add the "Social Media Widget" to the right top of my header, in the "header full width" widget area of the Custom Community theme. I put Twitter, Facebook and a custom service.

    Problem : when I test the links, they won't work with ordinary click. I need to use the right click of the mouse to open the links (not very easy for teenagers, who will use this website).

    When I simply click, I go to the home page instead of going outside to the social media. I must precise I've modified the "header.php" so that when you click on the header, it links to the home page (better ergonomy).

    I must also precise I've added a small picture (logo) in the "header right" widget area with a simple HTML code and when you click on it, you go to the picture url instead of going on the home.

    This makes me thinking there might be a problem with the Social Media Widget functionning if the widget area is located in a clickable header... Any idea ?

    I'm gonna test simply adding HTML code with icons and links instead of the widget, but it's too bad : the widget works perfectly when added in the footer area...

    http://wordpress.org/extend/plugins/social-media-widget/

  2. Nozkaer
    Member
    Posted 3 years ago #

    Config :

    WP : 3.3.2
    OS : Mac Snow Leopard
    Theme : Custom community
    Site : local (dev)

  3. brianfreytag
    Member
    Posted 3 years ago #

    Check your header logo size. I'm sure that the block element is overlapping the widget causing this. Unless I can see the site and look at your CSS/HTML using dev tools, I'm not going to be able to properly help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Social Media Widget
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic