WordPress.org

Forums

Social
[resolved] Display Name Contain Facebook and User ID # (3 posts)

  1. Mark
    Member
    Posted 3 years ago #

    I recently began using the social 2.0 plugin on my website and am having issues with the way Facebook users posts are displaying.

    A friend commented on a post earlier and her User name (both the one behind the scenes and the display name) became Facebook_FirstNAME_LASTNAME_##### (off hand not sure of the number of digits but clearly her Facebook ID).

    I didn't think that was a good thing out in the public so I have already gone into the comment created for her in WordPress and changed her name on the comment to correct this.

    I can't figure out how this is happening. I see a note in the release notes that the current version I'm using corrects this issue?

    I have tried duplicating but haven't been able to. I used a family members computer to test since they weren't connected yet. When I clicked the Facebook button, the window opened up to authorize the app for Facebook. I clicked through and the window went away. However, at first it seemed nothing happened. The comment area didn't show any change, i.e. it didn't look as if I was logged in. I hit refresh to reload the page and it now showed "I" was logged in. I commented and the comment came back with a regular display name. The username, etc. is still Facebook_login but the display in the comments reflects the actual name.

    I'm not sure what's going on - whether the one post from a friend where the name was as described was just a glitch or what? It definitely didn't behave as I would expect when I commented - I can't imagine a user would refresh the page if it didn't connect for them.

    Any suggestions on where to look appreciated. I know just enough to be dangerous.

    One website where I'm using this is:

    http://marketisdale.net

    http://wordpress.org/extend/plugins/social/

    http://wordpress.org/extend/themes/social/

  2. demo2
    Member
    Posted 3 years ago #

    I am also having this same problem -
    If my computer is logged into Facebook while I am viewing my WP website, the Facebook Social Plugin shows "Christy M***r was here" INSTEAD of the actual posts.
    If my computer is not logged into Facebook, the Facebook Social Plugin shows the actual posts.
    I use this plugin on 3 other WP sites and it works flawlessly (shows posts whether or not I'm logged into Facebook on my computer.)
    Things I've tried:
    Switching themes.
    Installing a fresh copy of my theme.
    Deactivating other plugins on my site.
    Site is http://www.shakeitwithkelly.com

  3. mc_nate
    Member
    Posted 3 years ago #

    Hey guys!

    I've been trying to replicate the same behavior but can't seem to get things to cooperate. Is it possible that these specific Facebook users have their information set to "private" within Facebook? We've tried a variety of security/privacy levels within Facebook and been logged in and out of Facebook but haven't been able to replicate the same behavior on this end of things.

    Are there any other plugins or themes that you're seeing this with? We'd love to get to the bottom of it.

    Give us a shout back and we'll be happy to keep digging.

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Social
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic